Octopi not able to connect to Ender3 V2 printer

Trying to connect to printer from the Octoprint webpage on the pi. I receive this message

State: Offline after error
No more candidates to test, and no working port/baudrate combination detected.

I can SSH to the pi and run dmesg:-

dmesg output:-
[ 631.189449] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[ 631.289353] usb 1-1.3: device descriptor read/64, error -32
[ 631.509571] usb 1-1.3: device descriptor read/64, error -32
[ 631.729419] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
[ 631.829400] usb 1-1.3: device descriptor read/64, error -32
[ 632.049305] usb 1-1.3: device descriptor read/64, error -32
[ 632.169457] usb 1-1-port3: attempt power cycle
[ 632.829319] usb 1-1.3: new full-speed USB device number 7 using dwc_otg
[ 633.269350] usb 1-1.3: device not accepting address 7, error -32
[ 633.369345] usb 1-1.3: new full-speed USB device number 8 using dwc_otg
[ 633.809331] usb 1-1.3: device not accepting address 8, error -32
[ 633.809566] usb 1-1-port3: unable to enumerate USB device

I have tried several usb cables, all to no avail.

Is there anything I can attach to the Ender3 usb port to check it?

1 Like

Hi Mike,

I haven’t run into your exact issue before, only issues where it doesn’t show up at all. You could potentially try shining a light into your port on your Ender and seeing if any of the contacts have been mangled at any point, and possibly try reflashing your printer.

I believe that the SKR Mini board that gets used on the E3V2 has a serial connection available, so you could possibly connect your Pi that way with some female/female jumper leads, but I use Klipper where you pick the port path, rather than Octoprint which can pick it automatically.

Keen to get you back on track with this one!

1 Like

James, I tried to send you an email with the octoprint log but got a reject. I shall try to send tomorrow from a pc rather than an iPad.


James, finally able to get octoprint and email on the same computer. The
octoprint log shows below.

I am very surprised that this problem seems to be reported in many
places and the best anybody can come up with is to get a new usb cable.
In the end I went for this solution but it had no impact.

I believe the problem is the board itself, I might add that I spent my
working life in the computer industry and diagnosing problems was, of
course, par for the course.

I cannot see a problem inside the usb socket.

If I have to get a better board then so be it but it shouldn’t happen on
a new machine.

Any further thoughts?

Changing monitoring state from “Offline” to “Detecting serial
connection” Performing autodetection with 7 port/baudrate candidates:
/dev/ttyAMA0@9600, /dev/ttyAMA0@115200, /dev/ttyAMA0@250000,
/dev/ttyAMA0@230400, /dev/ttyAMA0@57600, /dev/ttyAMA0@38400,
/dev/ttyAMA0@19200 Trying port /dev/ttyAMA0, baudrate 9600 Connecting to
port /dev/ttyAMA0, baudrate 9600 Handshake attempt #1 with timeout 2.0s
Could not write anything to the serial port in 5 tries, something
appears to be wrong with the printer communication Changing monitoring
state from “Detecting serial connection” to “Offline after error”
Closing down send loop


HI Mike,

I’d try connecting using Pronterface directly with your computer to make sure the serial chip on the mainboard is working correctly. This test will check that the USB cable and serial connection is working (If you have an RPi pico around you can verify with that as well).
If you can send and receive G-code then it will be something in the OctoPi config/Pi

The printer definitely shouldnt’ve shipped with a faulty chip, but isnt off the cards.


I installed pronterface and all it shows is connecting, but never connected.


Hi Mike,

Did you purchase the printer from Core in the last year? If that’s the case, and you suspect something is faulty, email us at our contact us page, and we’ll get straight into the RMA process.

Otherwise, outside of bad connectors, cables, or Pis, there’s a chance your motherboard is faulty in some way. If it doesn’t work on your PC then it seems Liam’s hunch on the USB-to-serial converter being dead is accurate. Are you still able to operate the printer normally through the LCD?

Keen to get to the bottom of this either way!


James I purchased the printer from you on 5/10/2021 and it arrived about 2 weeks ago. The printer works fine it is the USB interface.


Hey Mike,

I suspect that there’s an issue with either the continuity of the USB connection on your printer’s mainboard or with the USB-Serial conversion taking place inside the IC (which is one of the functions of the STM chip in the case of the E3v2).

Personally, I’d suggest taking out your main-board if you’re comfortable with that (after disconnecting the power and also a short pause before opening it up to avoid frying anything on the board) and checking that the solder job is clean around that chip and continuity with the USB connection doesn’t have any issues with it.

Typically when hitting timeouts like that in Octoprint it’s a pretty clear indicator that there’s a hardware issue with the USB connection to your printer.


Bryce, that was my impression, without the more detailed description of the interface. I returned the printer, as requested, last Monday.

1 Like

Hey Mike,

It arrived here in the warehouse a moment ago, we’ll do some testing and get back to you via email. We’ll need to get it set up and running here first around the other tasks we have to do through the day. But we’ll keep you in the loop as we go. Enjoy your weekend!

Hello I have a followed Klipper instructions for setting up klipper But I believe I’ve done something wrong because the raspberry 4 which I have got Failed to communicate with the printer.
then I have tried also MainSail…octoklipperpi…simplypi

The problem remain in the connection problem via serial port

The result is as follows
I can’t I can’t operate normally the printer from LCD or anything Because the LCD is Black I tried to flash back to jyers both printer and lcd
I can’t operate printer through Pronterface with the same port and band keep it’s keep saying connecting
please help me


Hi Ahmed,


When your printer starts up do you hear a jolting noise? (The steppers quickly locking)

It may sound like you have a dead mainboard.

1 Like