Rasp Pi 4B Octoprint Wifi Issues

HI All

I received my first RPi this week with the intention of using it to run Octoprint for my Creality 3D Printer over wifi.

I purchased an RP4b, sd card, RP power supply and RP camera all from Core in one bundle.

I followed all the guides and downloaded the Octoprint image using the RPi Imager. Configured my SSID and Passkey via the imager. (Headless setup)

After inserting the SD in the RPi it boots but does not connect to my wifi router (TPLINK Archer C1200).

So I have followed all of the troubleshooting guides edited the octopi-wpa-supplicant.txt file maually ensuring everything was correct. - No luck

I even renamed the default SSIDs in the router to remove any characters like underscores, then re-connected all the devices in my house - what a pain.

Re-edited the octopi-wpa-supplicant.txt file to match - no luck.

RE-imaged the SD Card numerous times, triple checking the country codes and time zones as well as the wifi credentials - still no good.

Re-imaged the sd card with standard Raspberry Pi image still no luck.

Running the ifconfig was sometimes showing no wlan0, and sometimes it was showing up.
Running the iwlist commands it sometimes scanned but showed no wifi networks, sometimes it would say wlan0 doesnt support scanning.

I have spent 14 hours on this today with no avail - i really think the wifi is broken on my RPi 4.

BTW it works perfectly on ethernet hardwire, ocotprint functions normally. Just no connection at all with wifi, either on the 5G band or the 2.4 band.

I don’t believe it can be this hard, I am not a newbie with computers and OS installs, been playing around since DOS 3.2, also been using Arduinos for years. But I will admit that this is my first RPi, so there maybe something I am missing, but my gut feeling based on the conflicting status messages is that the hardware is faulty.

I would be interested in anyone else’s thoughts on this. Apologies for not providing any screen caps from the various tests etc. It’s late here and been bashing my head against this for a long time.

If you wish to see the specific files etc, I can upload tomorrow night after work


Hi Brett,

I’ve worked with Fluidd, which has a similar setup to OctoPrint (has its own wpa-supplicant file) and the only thing that has gotten in the way for me has been poor signal. Since you’ve likely ruled that out, it may indeed be a faulty WiFi module on the board.

Could you send us a copy of your wpa-supplicant file with the password obscured, just so we can double-check nothing is amiss?

We can also run some tests with iwlist here to confirm the scanning issue is not just something simple like the command tying up the interface for a while.

While ethernet will likely speed up your print uploads quite a bit, I can understand the freedom of placement that WiFi offers. If we can’t get to a solution through troubleshooting here, reach out via the email on our Contact Us Australia page and we’ll organise an RMA to test it on the bench here.



Thanks James

Here is the last octopi-wpa-supplicant, straight from the RPi imager after using the settings icon to enter my wifi details, unedited by me

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


as you can see it has generated an encryption for the PSK. I have also tried editing this line and putting my PSK directly in enlcosed in quotes, and not enclosed in quotes just to be sure.

I have also tried adding the key_mgmt line as described in various troubleshooting guides.

Finally to rule out any range issues or incompatibility with my router, I set up my phone as a hotspot and the phone on the desk next to the Pi, still iwlist did not find any networks.

Hope this helps

1 Like

Hi Brett,

If you flash Pi OS on there are you able to see any networks?

Hi Liam

Thanks for your help, even with the standard PiOS iwlist showed no wifi networks.

I also logged in with VNC to try with the GUI but also no networks shown.