Particle Argon not connecting/flashing

I recently bought a Particle Argon and it has stopped working. I was setting it up to use the GY-302 ambient light sensor and attempted to flash an initial program but the flash failed, it was working previously for this. Now whenever I try to flash it, the flash is unsuccessful and I can no longer pair with the Argon with my phone, the setup eventually returns an error.

In order to pair with my phone, I have been doing a factory reset (holding the reset button and holding mode for a full reset) until the light starts blinking blue. I then scan the sticker, select my network, enter the password and it successfully pairs with the Argon. Whilst trying to connect to the Particle Device Cloud, it gets through Setting Wi-Fi credentials and Connecting to the Internet via Wi-Fi before retuning a message saying it couldn’t transmit Bluetooth messages. Sometime before this stage, the status LED begins breathing cyan as if it should be working, but the device does not appear on my PC.

I have tried factory resetting the board many times, flashing different programs which were previously working, repairing (which doesn’t work) and trying to pair directly from the PC using the device ID. I have been through the Particle Argon troubleshooting guide Status LED and Device Modes - Argon | Tutorials | Particle here, but it is not very useful anyway since it indicates my device should be working.

I have also been through every relevant forum post on Particles website and on Stack Overflow which I could find.

At this point, it feels like this could be a faulty device but if any help could be offered that would be great as I need to device for upcoming uni assessments.

Thanks for any help,

Aaron Norwood.

Hey Aaron,

Welcome to the forum!

Just to make sure we cover all of the bases, were you using the same account on both your computer and phone? Have you changed the firmware of the board, some users have run into issues regarding the bootloader compatibilities with the current firmware?

Definitely a strange one, I would try connecting to the board via USB to see if you are able to get feedback from any commands, Particle has a guide here:

Let us know how you go!

Hi Liam,

I’ve just double checked and I am running the app and my pc on the same account.

I have not made any changes to the boards firmware.

I have previously tried to install Particle CLI to try and fix it that way, however, I get an error saying “PATH not updated, original length 1053 > 1024”. I have used the registry editor to remove the cap on the PATH variables in the hopes of fixing this, however, it didn’t work. The installation for Particle CLI will finish eventually, but the resulting executable does not boot, I get a flash of a terminal which immediately closes. I have not managed to come up with any fix for this as of yet and upon retrying just now Particle CLI will still not install correctly. I don’t really know anything much about altering PATH variables, so I haven’t been able to figure out how to fix this installation error or if my attempted fix even did anything.




Was there any progress made with this, or should I be looking at getting a new Argon? I really need to try and figure this out ASAP so that I can start catching up on assignments involving the Argon.



A better solution would be remove obsolete entries from the PATH variable so that the length is less than 1024. It is likely that there are parts of the system that assume it won’t be greater than 1024, regardless of what the registry limit is.

One way to see that console window is to do a print screen the moment it flashes up, paste it into an image editor, and zoom in. There ought to be a better way but I haven’t found it.

So, I’ve reduced the length of a bunch of variables in my PATH and deleted some which were (hopefully) redundant. Particle CLI is now installed and works, but I can’t use it since my PC doesn’t have wi-fi capabilities and Particle CLI requires me to connect my PC wirelessly to my Argon.

Hey Aaron,

Sorry for the delay with this one. Our team hasn’t had too much of a chance to look at this with the weekend in between, but from the troubleshooting done so far, it sounds like the board is faulty.

If possible, follow up with our team and we will get the returns/refunds process started ASAP. Either reply to any of the emails linked to your order that we have sent you, or just email us at from the account you placed the order with. Just include the order number and the details you have about the board so far (a link to this forum post will do).

Let us know if you had any other questions or queries!