Pi 3 WiFi trouble

I am having problems with the WiFi on my Pi 3. It only sees my neighbor’s network, which is not that useful to me. I have downloaded and installed all latest updates and upgrades, but no change. My WiFi network works fine for the rest of my gear, so that is not the issue. The fact that the Pi is seeing a network seems to indicate that the WiFi is somewhat working, but how do I get it to see and connect to my own network? Any assistance will be much appreciated as I am totally new to this Pi business.

Hey Martin, are you using Raspbian?

Hi Aidan,

I assume so, whatever was on the SD supplied.

Looking at the messages during the updates, it appears it is something called Jessie??

The fact that it shows one (1) WiFi network (neighbour, not mine) maybe indicates that WiFi is partially working?



Hey Martin,

I’m leaning toward this being an aspect of the WiFi config. The Pi has some issues seeing WiFi networks on channels 12.

Go ahead and run a Raspi-config command in the terminal on your Pi. Then navigate to a WiFi Country Setting in these menus. From here you should be able to select Australia from the list. Save and Exit from Raspi Config and let us know if that helped you out.

If it doesn’t there is a software fix that has been successful for a few people, but first lets try the simpler method :slight_smile:

Hi Martin,

Aidan beat me to it … I believe the Pi3 can’t connect to WiFi on channels 12 or 13. If you router is using one of these change it to a lower channel. Also bear in mind the Pi 3 only has 2.4Ghz WiFi.

There might be some updates available to extend features etc - here are some tips.

Let me know how you get on - it certainly sounds like a config issue with your WiFi given you can see other networks.

Hi Graham, Aidan,

Thanks for this reply, it indeed was the solution.

My Router (Nighthawk X4S D7800), runs both 2.4 & 5GHz, (my newer laptops run at 5GHz).

The 2.4 was setup to select the channel automatically. I have changed that now to channel 11 and my Pi is happy!

Let the adventure in Pi-land continue.

Kind regards,



Nice! Glad to hear it’s working now.

1 Like