Pi Zero no longer booting

I’ve had a Raspberry Pi Zero in commission for a while now, initially I mentioned it here: Network share speed where I was first using it as a NAS for text files. It was doing fine for that purpose but I have since employed a Pi 4 to replace it.

As for the Pi Zero, I ended up mounting it to my desk along with a e-ink display and set up some scripts to display the current upcoming weather of the day. Wonderful. It was working like that for several months.

A few days ago, I had noticed that it stopped updating the screen. Thinking it was just another “API has changed now you need to edit the script” issue I put it low on my priority list. But after trying to gain access via SSH to it today to diagnose the issue, it wouldn’t respond at all.

So I detached it from my desk and tried running it by inserting a HDMI cable; nothing. I’ve tried the following:

  • Reinserting the USB cable
  • Using another USB cable
  • Using a different power adapter
  • Using another HDMI cable

Nothing at all. Not even the LED would light up. I pulled out the SD card and checked it on my computer, it’s still readable and can have files written to it successfully. As far as I know, nothing has been changed on the card between when it was working and now.

Even if the card is no longer readable, shouldn’t the Pi still generate an image over HDMI saying something along the lines of “can’t boot, no SD card”? I get no signal whatsoever over HDMI, which is making me think the Pi Zero has actually died on me.

If there’s anything else I could try please let me know.

1 Like

Tested a couple Pi-Zeros I have. Without SD card the green light will not come on.
So your Pi-Zero might still be ok.

The SD card is everything to the Pi-Zero, the SC card can still be functional in another PC but might not be Pi-Zero bootable. btw if you write to the SD card with a PC after the Linux image has been loaded it may make it non bootable. Linux uses a different file system to the PC.

The Pi-Zero needs a functioning, properly formatted, SD with valid image to operate. Without the card it has no smarts.

Suggest you create the SD card again and try it in the Pi-Zero. I suspect part of the SD card has become corrupt making it unbootable. Have experienced same situation with a Pi running for a long time.



I see! I had not been aware of that, I guess I must have confused it with a time that I had once accidentally booted my Pi 4 without an SD card.

Following that logic, I went and reflashed a fresh image of Raspberry Pi OS onto the card, and it booted up right away! I’ll be able to restore the files I created from a backup that I (first) created not one week ago. Fantastic.

But now I have to deal with the paranoia of not knowing what caused it to stop booting in the first place. I’ll have to take another look at my python code to see what exactly is going on, and if I had ended up unintentionally corrupting some system files or some non-sense.

Thank you for the info, I’ll keep that in mind. A completely unresponsive Pi Zero might be caused by a faulty SD card, whereas if the same thing happened on a Pi 4 it would at least still give you an image on the HDMI telling you that there’s nothing to boot.

1 Like