Raspberry Pi Zero W No power

brand new, can’t get it to boot. I have tried different SD Cards, 3x different power supplies, different displays, etc. I have a working RPi3 that I am using to test for known good peripherals.

The most interesting thing I can get to happen is with an SD card inserted and power applied, the green power LED flashes once or twice. With no SD card, no flash.

Anything else you can suggest please before I apply for a RMA?

The LED on the PZW is for activity. Since it only flashes once when an SD card is inserted, and you’ve tried multiple cards, I’d say there is something wrong with how you’re flashing the image to the card.
What image are you trying to flash?
If you’re on Windows, have you followed our SD card repair tutorial before reattempting to flash Raspbian onto the card?

1 Like

OK my bad.
I was trying to boot FlintOS for Chromium and did not realise it is not yet compatible with Pi Zero.
Also did not know the LED was activity.

Installed NOOBS and it seems to be working. Could have saved myself hours if there was good documentation.

*it’s also possible that there IS good documentation and I threw it away in my desire to get going quickly.

Thanks Michael