PI4 won't boot


I am a newbie to RPi and bought a PI4 in November. I managed to run a few OSes with PINN. But, all of sudden, it won’t boot and has no signal from the monitor(tv). I thought it was a HDMI issue but it looks like the consistent green light issue. So, the red and and green lights are ALWAYS ON with and without SD card. Any tips to solve this?

Many thanks in advance,


Can you make another boot image and try?
Were you using the new version of the OS?


my advice to you would be this crate a noobs op-system disk use a 16 gig card sandisk class 10 type if you can get one or a brand new sd card

your boot rom may be corrupt …browse the rpi official forums for boot up advice if it still will not boot… cannot remember the led code`s sozz rusty

1 Like

Thanks guys,

I tried re-writing SD cards and modifying config file etc. Had no luck. I had 2 SD cards working. None of them are working. If there is no SD card in shouldn’t it still says “SD Card not detected” on boot screen? I don’t get any screen signal.

1 Like

Hey Tinyme,

So that we can get your project back on track as fast as possible can we get you to run through a few debugging steps so that we can get your project back up and running as fast as possible?

  • Ensure that HDMI is connected before the power and is connected to HDMI0 (the one on the left when facing the HDMI ports).

  • Try removing the SD card and powering on the Pi with HDMI connected to HDMI0. If you get video output and a bootloader screen there is a high probability the issue is with the SD card or software, not the Pi itself.

  • If using your own uSD (not a preloaded NOOBS from us), we recommend BalenaEtcher or Raspberry Pi Imager to write the freshly downloaded image to your USD (this fixes most boot issues, due to incorrect formatting methods)

  • If using your own uSD, you will need to use the newest version of Noobs or Raspbian for support of new board variants.

  • Check that the bootloader is correct with the recovery steps.

  • Have a look over this thread that has a lot of advice on boot issues.

  • Check that the SD card has not been damaged by a drop or mishandling (uSD should be removed when installing Pi into a case to avoid snapping the uSD).

  • Ensure you are using a power supply that can provide 5.1V (not just 5 Volts) at a minimum of 2 Amps

  • Check the HDMI cable connectors for damage. Shine a light (phone torch would suffice) into the connectors and check for dislodged/damaged pins.

  • Check the Power Connector (both on the Pi and on the lead) in the same way, inspecting for dislodged/damaged pins.

As all RPi boards are electrically tested post-manufacture, in the majority of use cases we find the uSD is at fault (we have replacements here if you don’t have one handy).

I hope that information helps as we’ve discovered that returned RPI’s are consistently fixed with one of the above steps (avoiding you the expensive bi-directional shipping costs of a no-fault return).


Thanks Oliver,

I think I tested what you mentioned but I will go though your tips again to be sure when I go back home from my holiday.

Just a couple of questions. I installed Raspberry pi imager on Windows 10 in November and I wrote Raspberry pi OS on my SD card. Is it how I get the latest version or do I need to check if the imager is latest?

I tested to boot my Pi without my SD card before and I didn’t get any signal on my TV. But, the status LEDs were solid (green and red) and were not blinking at all. What should they be like if the Pi is normal?

Thanks again.


If the green light is ON with the SD card in, then it means the SD card is detected. Check this thread, Nathan had similar symptoms. The problem was the USB drive.

As Oliver mentioned, all connections, especially HDMI, should be in before powering up the PI. HDMI 0 is the one closest to the power in USB3 connector.

In any case, try using Sandisk or Samsung EVO micro SD cards. I was using a different but UHS 3 class card on my Pi Zero W. It would have issues booting, but the files are readable using an external card reader. Finally switched to a Samsung Evo UHS 1 class. The issue went away.


the rpi is working to some degree try a new cable also try moving to different port om your t.v and different port on the rpi make shore your set is on before powering the rpi and check the 3.3 and 5 volt rails with a dmm


if the boot loader was at fault you would not be seeing both leds so installing a fresh copy of noobs is handy and a brand new sd-card…
if incorrect power downs have corrupted the first sd-card or the data…
…a latest copy of noobs will update the boot loader if necessary automatically…at boot up generally…you can edit it your self if you want-to boot from usb instead…0x4 is the code i use.
for faster boots from usb memory devices… use storage quirks…browse the web for more info on this topic…sd-card have a read write life cycle generally …most users don’t need to worry about this though…


have you solved the problem…???


Hi brian86770,

Thanks. I’ve done some testing.
I bought a new SD card and installed a fresh OS(es) and still didn’t work (no signal on TV/monitor).
And, I also bought a Pi Zero W and tried the same SD cards that didn’t work on my Pi4 and they all worked on the Zero. So, no SD card issue.

I asked a IT guy at work to test it out. With all the same conditions, my Pi4 didn’t work but, the work one(Pi4 also) worked.

So, I suspect that the status light(solid and no blinking at all) has something to do with the issue. I will have to send it back to Core Electronics to have a look.



Hi Tinyme,

Thanks for running through those steps - swapping out the Pi and keeping everything else the same is some good intel. It’s very unusual that it was working and now it’s not. Something must’ve changed between then and now :thinking:

If the green led does not blink when you power it on without an SD card, that indicates there is a problem with the EEPROM, so you’ll need to try and recover the bootloader before anything else will work.

bootloader recovery

Can you share some photos of how you have had it hooked up? Just in case we can spot anything amiss?

If after writing the SD Card Bootloader recovery configuration to an SD card, the Pi still shows no signs of life I think it’s likely to be dead. Pi’s are fairly resilient, though a bad power supply or a really good zap to the GPIO could do it. It’s important to try and find the root cause, else a replacement Pi may well suffer the same fate.

Yep, using Pi Imager will always get you the latest stable images. It downloads a list of latest files every time it starts.

Just as a point of interest, here’s the source for the list of OS’s in Pi Imager:
And the list of EEPROM recovery images:
You can actually also direct it to use custom repository, instead of using the official Pi one with a command line switch.