Raspberry Pi Zero W

I bought a RPi Zero W but can’t get it to connect to my wireless network. I’m running it headless so can’t show status.

I have followed steps as per this page:

Any ideas?


Hi Pete,

Those instructions are for the US so if you’ve copied out the commands verbatim it won’t work.

I’d suggest having a go with our tutorial:

The issue is that different countries manage their RF spectrum differently, so WiFI in the US is not the same as WiFi in Aus is not the same as WiFi in the EU. This is why WiFi is disabled on Raspberry Pi’s until you configure the locale settings - else you might be accidentally breaking the law!

Hi Oliver
That’s good information. I went through the process again as per your info but still no luck. Interestingly when I look at the contents of the sd card after attempting to connect to it I find that the “ssh” file and the “wpa_supplicant.conf” have both disappeared. I’ve read a few things that seem to indicate that this is a bug with the raspberry pi os that is based on Debian “buster”.
Unfortunately none of the other RPI OS distributions that I’ve tried seem to work either. DietPi doesn’t boot (it doesnt seem to have a config option in which you can specify your country) and I cant seem to download archlinuxarm properly. The zero seems to be a bit of a dead end. I’m curious to learn what other peope have been able to do with this and the current OS versions.
I’ve managed to configure other RPI devices but not this one.

That’s not a bug, it’s a feature.

Have you tried setting it up locally? Troubleshooting networking issues over a network is a nightmare.

Doesn’t work with PiCorePlayer either. I will try a different SD card (although if it is faulty that would have been exposed when writing to it).

I’d recommend sticking with Pi OS. It’s the most stable and reliable. If you can’t get it working with that you definitely won’t get it working with any other OS.

Hi Oliver
How/Why a feature?
Why are the files removed - because they’re not working or not required? Don’t understand.

The setup is trivial if it is not buggy. I’ve done it with a few other devices. This device is probably faulty.

/boot/ is not the correct location for a wpa_supplicant file, it’s no good there, but as /boot/ is a FAT32 partition, you can conveniently create and edit the file on Windows or Mac OS. It puts it in the correct location under /etc/ on startup.


Pi OS executes a mv command on startup to put it in the correct location. Having it move from that location is a nice confirmation that it’s loading the file (if it doesn’t disappear you know you’ve done something wrong, whereas having stay there after a successful read gives you no feedback either way).

Check out this thread for more technical details:

I’d recommend getting a clean image of Pi OS and trying again. If still no luck, make sure you’ve actually got a WiFi chip detected!


Thanks for the info. I managed to get picoreplayer installed with same settings as i used on other distros. Don’t know why it worked on some and not others. I didn’t really need that specific functionality but now that it’s there I’ll play with setting it up as a streaming device.


Glad to hear you got it running!