Pi W WiFi not working

Hi All,

Last week I ordered a Pi Zero and a Pi Zero WH (I am lazy and didn’t want to solder the header :smiley:)
This all duly arrived in the post and so the first job was to set up the OS.

I downloaded Raspbian Buster Lite from the Official Website 2019-07-10-raspbian-buster-lite
and wrote it to SD using Win32DiskImager. I then used Notepad++ to edit the config.txt file
and the wpa_supplicant.conf files as per the Instructions from the July 2019 Silicon Chip p48
Speech Synthesiser Project. All went well until boot when WiFi refused to work.

The Interface wlan0 exists but there is no indication it has connected (ie. no IP address) when
I use the ifconfig command. DHCP is definitely running and looking for a connection. There is
definitely no network connection - ping cannot get out. (This occurs on all versions of OS used)

After checking the config files and finding no errors I re-burned 2019-07-10-raspbian-buster-lite
and tried again with a vanilla config file (ie. minimum info to get it to work). Again - No WiFi.

After checking the Raspberry Pi Forums I discovered that there is an issue with WiFi that requires
the Country Code to be set in the config files, which it was, but the issue was limited to Buster.

I also checked the Official Raspbian site and there was no further information.

I have subsequently tried installing
2019-07-10-raspbian-buster-lite Several times
2018-11-13-raspbian-stretch-lite - The version in the original SC article

I have verified img writes each time and even the Graphical versions are not recognising
any Wireless Networks when searching. I have even used 7-Zip to unpack images from
their corresponding Zip files (as recommended by RasPi Org).

It seems strange that FOUR different versions of the OS cannot make this work. The Pi Zero
is booting normally and everything else seems fine. There are no error messages in the logs
I can see. It is DEFINITELY a Pi Zero W ver 1.1 so I have not mixed it up with the Pi Zero I also
ordered (without a pre-soldered header). I can see no VISIBLE damage to the Pi and my anti-static
protocols shouldn’t have cooked anything.

I have experience with Raspberry Pi 3 and 3B+ and so far everything works fine - I just cannot
get the Pi Zero W WiFi working. So in a word - Help.



Hi Andrew,

Sounds like you’re giving it a red hot go! Nothing is stored on the Raspberry Pi, you should be able to put that card into any compatible RPi board and it will boot/connect as normal.

You mentioned you have a 3 and 3B+, do those boards connect to WiFi when the same uSD card is fitted?

And regarding:

It’s a requirement from Stretch onward.

Ok - more information.

I have used the SD card from the Zero W in a 3B+ known to work on WiFi and I am having similar
problems. This says to me it is a configuration problem of some kind but I am not sure what.

rfkill reports no hard or soft blocks
ifconfig reports wlan0 is NOT connected
sudo iwlist wlan0 scan reports the two different WiFi routers are available

I have been using this webpage and others to troubleshoot:

My config.txt file has been modified in the following way:

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable the lirc-rpi module

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable UART

This should not affect WiFi and it doesn’t work with the default config.txt either.

My wpa_supplicant.conf looks like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev



A default wpa_supplicant.conf that is simpler also doesn’t work using the Network
discovered by sudo iwlist wlan0 scan

Any suggestions?


I set up a headless Pi Zero W just a few weeks ago and it has been happily running 24/7. I SSH into it almost daily. It is running Buster Lite.

This is my wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Then I logged into my router administration settings, found the IP address of the pi and SSH to it with:

ssh pi@2017.168.3.104 (not my real IP)

That’s all there is to it. If you can’t see the Pi in your router administration settings, then you know that the Pi has not connected. Don’t forget to change the default password for default user ‘pi’.

I’ve reinstalled Buster Lite on the SD card several times for various reasons, and the Pi Zero W connects to wifi every single time.

EDIT: Also, is your wifi 5Ghz? The Pi Zero W can only connect to 2.4Ghz.

1 Like

HI Again,

The Pi is DEFINITELY not connected to the WiFi. There are two 2.4Ghz networks it
could connect to that it can “see” using the sudo iwlist wlan0 scan command. The
ssid and psk ARE the correct settings in wpa_supplicant.conf