Pi Zero with Dotstar LEDs

Hi all, totally newbie question - does anyone have a wiring diagram for connecting a pi zero w to a set of Dotstar LEDs? I’ve tried various configurations I’ve found on the web but none are delivering the outcomes the tutorials suggested; I either get wildly flashing lights or a single white light, neither responds to the strand test.py instructions.

I’m using the adafruit T-Cobbler into a breadboard currently.


Hi Andrew,

The Dotstar LEDs use SPI so you just need to connect them up to the SPI port of your Raspberry Pi. I used DotStar (APA102 drivers) LEDs in my Pixel Panel project: https://core-electronics.com.au/projects/led-pixel-matrix

So take a look at the Raspberry Pi pinout, and it shows you the clock and data out (MOSI) lines: https://www.jameco.com/Jameco/workshop/circuitnotes/raspberry_pi_circuit_note_fig2a.jpg

Hi Sam, thanks for getting back to me; I must be doing something silly or missing an obvious step as I’ve torn down the setup i had and gone with this one but the results is the same - the LEDs have power but just do their own thing. The thing that i’ve noticed is that when the GND is connected to Pi less lights are on, and when disconnected they go “a bit crazy”; I’ve notice noticed that the DotStar’s have an extra cable as compared to most of the examples I’ve seen on the web 5v power + and, then GND, CO, DA, VCC on the main strip - i’m using the external power pack to run the LEDs, with the Pi using USB power.

At the moment, I’m using a logic converter (after having tried your suggestion).

As I said, I think I’m missing something simple; do you have any advice on some basic debugging to try and establish a connection & control between the pi and LEDs?

Have you got a common ground between the power supply (aka, the strips) and your Pi?

Hi Sam,

I think so; I’ve got the 5V connected to the red & black cables via the barrel adapter, then the black cable on the strip (next tot he green/blue in the picture) is connected to the GND on the Logic shifter and then jumped via the bread board to the GND on the Pi. I double checked the behavior this morning, this with config and when I powered the strip on, no LEDs were lit up; then I removed the jump from between the pi and logic shift and the strip lit up like a Christmas tree.

Hi Andrew,

Hmm ok, could you perhaps draw out all of the connections that you’ve made? It’ll help me to work out if anything is missing

Hi Sam, here’s what I have connected.

Hmm, try bypassing the logic level converter and driving the data and clock lines directly from the Pi. I’ve done that myself before and the 3.3V level is enough to trigger the logic level for the driver chips. That’ll simplify things and show whether it’s a software or a hardware issue.

Hi Sam, I found the issues was using the bread board to connect everything up; when I attached everything together without the board it worked like a charm.
Thanks for your help getting this sorted.

1 Like

Awesome! I’m glad to hear it Andrew. They’re the issues which make you want to give up on the project, when you can’t see what’s gone wrong. All the best with the rest of your project :slight_smile:

Dotstar have one better LEDs which can replace APA102