Pimoroni Non-Touch – HyperPixel 4.0 - Hi-Res Display for Raspberry Pi (CE05549)

This is a placeholder topic for “Pimoroni Non-Touch – HyperPixel 4.0 - Hi-Res Display for Raspberry Pi” comments.

HyperPixel 4.0 is the perfect way to use your Pi without a bunch of cables or a bulky display. Design your own interface to control your project, display data, or turn your Pi into a tiny media center.

Read more

Any ideas on how to get this to work. We tried the GitHub stuff but each time it failed. The error was something like Unable to fetch

1 Like

Hey Fergus,

I have one of these myself and the one line installer worked fine. Do you have a solid internet connection on the Pi?

The github is still up (though I noticed there’s a fork for boards manufactured this year):

1 Like

Thanks for the reply Oliver. Yes, the internet is solid. I logged an issue to GitHub.

The only thing I notice is that the i2c is not installed.

I checked the mirror detect websites and they are definitely not active,

Can you send me the log of your install so I can see what websites your install accessed.


Here is the log. Have tried this now around ten times with different configurations, I did notice that the I2C and SPI interface were not enabled on the Pi but they are now. Here is the log below. Not sure if that main issue is the fault weblinks but clicking on them shows the webpages are not active.

pi@raspberrypi:~ $ curl -sSL https://get.pimoroni.com/hyperpixel4 | bash

This script will install everything needed to use

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: ‘curl https://get.pimoroni.com/hyperpixel4

Do you wish to continue? [y/N] y

Pick your HyperPixel 4 and Raspberry Pi combo below:
0 : Rectangular - Pi 3B+ or older
1 : Rectangular - Pi 4 / Pi 400
2 : Rectangular - Pi 4 / Pi 400 - Experimental Touch Fix
3 : Weirdly Square - Pi 3B+ or older
4 : Weirdly Square - Pi 4 / Pi 400
Press Ctrl+C to cancel.

If you have problems with your install
let us know: https://github.com/pimoroni/hyperpixel4

Enter an option [0-4]: 3

When did you purchase your HyperPixel Square?
0: 2021 or later
1: 2020 or earlier
Press Ctrl+C to cancel.

If you’re unsure, don’t worry, you can change your /boot/config.txt later.

Enter an option [0-1]: 0

Installing Weirdly Square for Pi 3B+ or older
for HP manufactured 2021 or later.
Is this correct? [y/N] y
Using git branch: square-2021

Checking environment…
Updating apt indexes…
…W: Failed to fetch
404 Not Found [IP: 80]

W: Failed to fetch
404 Not Found [IP: 80]

W: Failed to fetch
404 Not Found [IP: 80]

W: Failed to fetch
404 Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old
ones used instead.
Apt failed to update indexes!
pi@raspberrypi:~ $ …
pi@raspberrypi:~ $

1 Like

Just heard on Pimoroni forums that my Raspberry Pi is using an old version of is (Jessie) so need to upgrade.


I’ll have to see if I can dig it out, but yep, running sudo apt full-upgrade and sudo apt update is always a good first step

1 Like

OK. I have been on the Pimoroni forum a lot. They have given a lot of tips but still no action.

I have an old RPi 3B (2015). I reflashed the micro SD card to Buster using the Raspberry Pi Imager and now the curl -sSL https:\\get.pimoroni.com\hyperpixel4 | bash does actually work but on reset the whole system hangs. Probably best to buy this display with a RPi4. I will try on a PiZero ordered recently and report back.


All good now, thanks. After upgrading to latest RPi Os (Buster), all I had to do was connect Ethernet to RPi, type in curl -sSL https://get.pimoroni.com/hyperpixel4 | bash, select option 0, reboot and wait 30s or so to let Rpi startup. I fell over at the last hurdle - waiting for 30 seconds. I had a lot of help on the Pimoroni forum.