Py scrips errors

Hello i am Ben from Holland, and i have tried the py script (4G and GPS HAT For Raspberry Pi - Waveshare SIM7600X - Tutorial Australia
This is giving me python errors … Is this known? Other scripts are running fine!
What go’s wrong here, am i doing something wrong i now nothing from Python …

Greetings Ben

1 Like

Hi Ben,

Welcome to the forum :slight_smile:
We’ve got a big thread with troubleshooting help for that guide which you can find here:

Can you give us some more information about the error messages you are getting? When you mention other scripts running fine, were you able to run every previous script mentioned in the guide up until that point? Or were these scripts you found elsewhere?

Those scripts worked when the guide was written so it’s possible it’s just a simple error like the indentation and spacing has changed or a text editor has changed the code slightly when it was copied, this happens from time to time with hidden characters added that mess up the scripts.

1 Like

This is the error it is showing me…
File “/home/pi/”, line 110, in send_at
FinalLat = float(Lat) + (float(SmallLat)/60)
ValueError: could not convert string to float: ‘,0’

Hey Ben,

It looks like the Small latitude (the fractions after the dot point in the latitude) is running into issues when converting to a float.
If it is happening in this script, I would assume you are also having an issue with | |
Are the other scripts that are in the guide showing a similar error message, or is it just this one?