Pycom Lopy not in device manager

I cannot get the Pycom to appear in Device Manager. I have updated firmware. I have tried 3 diff cables. I have installed ATOM and can change the LED colour, can connect to wireless LOPY, but cannot get to a serial port as it does not appear in device manager. Win10 Pro.
Any advice?

Hey Andrew, @Chris should be able to shed some light on this for you tomorrow.

Hi Andrew, I think it’s awesome that Pycom let you program their devices over WiFi :slight_smile: but I work on a serial connection mostly. You’ll need another device to interface between your LoPy and a USB connection. A Pycom Expansion Board 2.0 will take the LoPy on top and provides a micro-USB socket at the edge. You’re not stuck with using Pycom gear. Any 3.3V FTDI device (note: not 5V!) can be connected up using the pinout diagram.

Please reply here if that doesn’t solve your issue. I’m here to help!

  • Chris.

HI. Yes I have the expansion board, and was able to update the firmware etc using a USB connection. But I cant see the device in device manager, cant update the software and cant proceed along your tutorials.

Alrighty, if I remember rightly, the firmware update app will automatically select a port on the Communications screen. If you go back through the Update Firmware process, you should be able to get to the Communications screen and see which Port is selected there. If, for example, it says COM5, you should be able to open Device Manager and open Ports (COM & LPT) and find your device there listed as “USB Serial Port (COM5)” if it’s a Pycom Expansion Board 2.0 or “USB Serial Device (COM5)” if you have a Pysense or Pytrack.

The most detailed instructions we have are in Internet of Things with Pycom and Adafruit IO - From Zero to Hero. Otherwise, the Pycom documentation you need is very good. I see they’ve updated it for the Expansion Board 3.0, which I haven’t seen yet.

Let me know how you go?

  • Chris.

there are no ports to open in the device manager, presumably because there was no device being detected.
I have followed your tutorial to the point where I have to select a comm port in Atom. I have searched the Pycom docs as well. You cant update the driver without selecting the device in the first place. Even when I redo the firmware update and note the port I get this error when I try to connect in atom.
getaddrinfo ENOTFOUND com3 com3:23.

Might be best to touch base with Pycom for this one then Andrew, and let us know what the way forward was!

OK. I will keep trying.



1 Like

Going at last. Not sure of solution. Repeated firmware updates and likewise repeat PC restart was in the mix.


That’s great to hear Andrew. Thanks for letting us know!

Now stuck on IOT tutorial. Big fat red light I cant seem to solve.

Where in the tutorial are you stuck - what have you tried?

Sorry Graham, I missed your message. Windows 10 update then removed ATOM IDE and I kind of lost enthusiasm.
I am stuck I think at line 38 of the IOT tutorial. # Status red = not working.
After setting up Adafruit, After learning how to change the LOPY LED colour and frequency. After copying in the code provided by Chris.

1 Like

Chris, I wonder if I have the Wifi SSID and Password for the wireless network settings in IOT project correct?
Can you confirm where to obtain them?

Hi Andrew,

If you’ve copied the code file under the heading Atom Project you will need to change a few of the settings at the top of the file, under # Wireless network and # Adafruit IO (AIO) configuration.

If your device is turning the LED red and then not doing anything after that it looks like it’s the connection to your wireless network that’s failing. Can you please check WIFI_SSID and WIFI_PASS are set correctly? This should get to turning the LED orange.

If the above doesn’t fix it, can you please check if your Wi-Fi access point is using WPA2 authentication? We might need to change another line of code if it isn’t:

wlan.connect(WIFI_SSID, auth=(WLAN.WPA2, WIFI_PASS), timeout=5000)
  • Chris