Raspberry Pi Media Center Kit

I’m going to buy the Raspberry Pi 3 Media Center Kit, but I’m unsure if I should buy the Miniature WiFi module as well.

From the Miniature WiFi module page:

If you have a model B you may find that you need to have a powered hub to use this adapter, so if you’re having power flakiness with your Pi, try a hub!

Does this still apply to the Raspberry Pi 3 Model B? Can I use the Miniature WiFi module without a powered USB hub (or any USB hub)?

Also are you absolutely sure this Miniature WiFi module can stream videos in HD?

Hi Ahmed,

I would suggest getting the Media Centre kit first, seeing if it works as you want it to, then look at a dongle if it’s still not performing as you would like.


I just bought my Raspberry Pi Media Center Kit. I chose express post shipping so hopefully my Raspberry Pi Media Center Kit will arrive before next week.

1 Like


I forgot to ask if there is a warranty for the Raspberry Pi 3 Media Center Kit.

What do I do if I have any problems with the Raspberry Pi 3 Media Center Kit?


I just talked to online chat, and they said the Raspberry Pi 3 Media Center Kit comes with a 12 month warranty.


Where is the Raspberry Pi 3 Media Center Kit being sent from? Is it being sent from Newcastle or somewhere else?

Hi Ahmed,

We are located in Newcastle. If you have any order inquiries, please email us at support@coreelectronics.com.au


The Raspberry Pi 3 Media Center Kit just arrived.

I will open the package and set it up later in the day.

I already have a microSD card reader to use if I want to put LibreELEC or OSMC on the microSD card.

I also have an external hard drive with videos.

1 Like

Sounds great Ahmed, best of luck with the projects!


I set up my Raspberry Pi 3 Media Center Kit.
I decided to go with LibreELEC and I put LibreELEC on the microSD card.

The Raspberry Pi 3 booted up to LibreELEC, and I’ve set up my time zone correctly.

The Raspberry Pi 3 and the other hardware (keyboard and trackpad etc.) seems to be working so far.

I can connect to my home network wirelessly, but I haven’t tested YouTube streaming yet.

I connected my external hard drive to the Raspberry Pi 3, and I can play most of the videos even without the additional codecs.

But none of my videos have thumbnails. My external hard drive only has 1-2 GB free storage, could that be the problem?

I installed the YouTube addon and played some YouTube videos in HD using WiFi, and they seemed to play fine.

Also is it safe to leave my Raspberry Pi 3 on 24/7 with an external hard drive connected?
I don’t like having to unplug its power and plug it in back again every day.

I got some thumbnails to show.

I went to Media Settings>Videos and enabled “Extract video information from files” and “Extract chapter thumbnails”.
But I still don’t get any thumbnails for .mkv videos.

Hi Ahmed,

Thanks for the feedback. It’s perfectly safe to leave your Pi plugged in like that, and as far as help with Libre goes, I’m not 100% sure sorry as I haven’t used it myself. If you’ve got more questions about your order, feel free to email us at support@coreelectronics.com.au

Hey everyone,

Back when I first started fiddling with the Raspberry Pi as a retro gaming and media centre platform, all the standard advice for watching local TV channels seemed to involve connecting an antenna to a USB TV Tuner. It was all a bit of a hassle for a thing you’d only use now and then. Especially if the wall port for your roof antenna is in a different part of the house.

But since then, some cool Kodi Add-ons have become available to make it easy to access the official free-to-air streams from Freeview. So now we can watch the cricket :smiley:

I’ve put some instructions together on how to do this, for those who are interested:




Neat! Thanks for sharing James.

Just tried this myself, and it works pretty well :smiley: Just as a note, “AU Freeview” has been renamed to “IPTV AU”. Other than that, your instructions were very clear James, so good work. I could only get half the channels to work properly (12/22), but I suspect that’s a source issue.

1 Like