LibreElec on Raspberry Pi 3 A+

Hi Guys,
Wondering if anyone has been able to get LibreElec running on the new 3 A+?
I received mine yesterday and haven’t had any luck. Tried the Pi2/3 image from the LibreElec page, tried via NOOBs default, tried adding folder to NOOBs OS folder as explained on LibreElec web page.

I can get Raspbian running without issue. But LibreElec just gives me blank screen after rainbow splash.

Hey Sergio,

I was able to get LibreElec to boot by updating to the most recent alpha version (8.90.007). You can download it from that page, you may need to get 7-zip or something like it to extract the gz file. But that seems to get it working for me. Let us know how you go.

Thanks Clinton! Got it working. I’d already downloaded that img last night so used etcher to transfer to SD card. This time I noticed that it failed, so I gave the SD card a thorough format and tried etcher again. Still failed.
So I tried using the LibreElec SD Creator, all with the same img file and that transferred ok. Now have Kodi up and running and watching movies!
I only persevered because I knew you’d got it going so was confident that it was possible - thanks mate!


No worries at all, it is weird that it would give you so much trouble but I am glad you are up and running!