Raspberry Pi Zero freezing when installing Raspbian

I recently bought the Raspberry Pi Zero WH. Downloaded Noobs and put onto a 64GB card, following the various instructions about how to format a card over 32GB in size to make it usable.
I put the card into the zero, and it came up with the install screen, with two OS to choose from. I selected Raspbian and clicked install. The install only got as far as 10% before freezing. Nothing happened after that. Left it for over an hour with no change. Unplugged the Zero and tried again.

Tried this same thing multiple times and the % changed anywhere from 0% to 92%. Generally, it was around 10%. It only got to 92% once (and rarely ever got over 40%), and then it ended up the same as the picture in the next sentence.

Sometimes instead of freezing, the image on the screen would distort similar to this picture at https://i.stack.imgur.com/Op2se.jpg (image found on internet, not a photo of my problem). I wondered if the install was still happening in the background of this mess, and left it on to see if it would resolve itself, but unfortunately no…

Other times the Zero wouldn’t go to the install screen, but lines and lines of scrolling code would appear.

Occasionally the message would be a tarbull error (can’t remember the exact wording of this error)
I wondered if it could be the card, even though I had followed the instructions online on how to format it. I then bought a preloaded SD card with Noobs. Same issues as above.
I have re-downloaded Noobs and reformatted the card, and still same problems.

Things that I wouldn’t have expected to make any difference, but did them regardless:

  • At first I was using a usb to mini usb cable attached to power the Zero. Can’t see why it would be the problem, but I then bought the Raspberry Pi 3 Power Supply (Official) from you just in case. No difference.
  • Changed the monitor from being VGA attached via an HDMI-VGA adapter to just directly with HDMI
  • Originally tried with a USB apple keyboard and wireless mouse that uses a USB receiver plugged into the keyboard. Changed to a different usb keyboard and removed mouse. Same issues
  • Removed keyboard and used just a wired mouse. Same issues.

I am at a loss as to what else the problem could be. Any ideas?

Hi @Lucas56902,

Something is unstable and there are really only two moving parts worth chasing: power and uSD card.

I’m leaning to the uSD card and would recommend you try decent brand (that is a real class 10) and is 8-32GB. If someday you need more space then you could use an external thumb drive for heavy-media, or perhaps a network share.

While a 64GB uSD is fine by design; there are known compatibly issues with some card variants. If you wanted to be totally sure, then you could always grab one of our Official RPi Cards that are preloaded with NOOBS.

Let me know how you get on.

Thanks Graham, I did buy a pre-loaded card from Jaycar, and had the same issues. It is very frustrating as I’m sure you’ll appreciate! I’ll have another go on a third card and see what happens. Thanks, Lucas.