Unable to install Rasbian on Raspberry Pi 3 B

I received my raspberry Pi yesterday, I have managed to load the SD card, and boot it up, but Rasbian will not install, it loads for around 20-30%, then just drops out and re-boots. i’ve tried countless times with the same result.

Hi Frank, thanks for the post. It sounds like you’ve done everything correctly on your end.
It’s my understanding that you’re using the NOOBS installer. What size SD card are you using?

The workshop originally specified 4GB but we found this to be cutting things too close, so we’ve updated it to an 8GB minimum.

The reason I suspect it’s a SD card size issue is because NOOBS unpacks Raspian on the first boot, and as this process is running, perhaps NOOBS runs into a problem where it has consumed all the space available on the card. That might be why the first-boot process gets part way through before failing.

Let me know your thoughts,

  • Michael

I’m using a 16gig SD Card.
I’ve formatted it and installed NOOBs as per instructions on your website. I then put the SD card into the Raspberry Pi. It fired up okay and then when I went to install rasbian, it would look like it was progressing, then stop after a while and would restart back to the install screen.

Sounds like it’s time to check the basics then:
How are you powering your Raspberry Pi? The power supply should be capable of at least 1.5A for just running the Pi, but the official recommendation is 2.5A which is enough to power the Pi and a few peripherals plugged into the USB ports.

If the power supply is under powered the Pi may still start to boot, but once it hits heavy processor load it may demand more power than the supply is capable of.

When you say you’ve formatted as per instructions, does that mean you’ve tried cleaning the sd card (windows), and then installing NOOBS?

I formatted the sd card using the formatter here https://www.sdcard.org/downloads/formatter_4/
I’m using a mac.

Currently plugged into the Pi are an HDMI cable and a wireless receiver for a keyboard and mouse.

Also, the power supply I am using is an old blackberry charger which I’m pretty sure is 5v output, but I’ll confirm that when I’m back in front of it which will be in a few hours.

I can confirm that the power supply is 5v - 700mA


Thanks for taking the time to post a picture, that really clears things up. Power is definitely the problem! Raspberry Pis are pretty power-hungry. 700mA = 0.7A , which is roughly half what you need to get stable operation out of your Pi.
In a pinch you could try USB tablet chargers like those for iPads etc - these are often 1.5A capable. You’ll just need a micro USB cable to connect the charger to your Pi.

To summarise, your power supply must be exactly 5V (DC) and greater-than-or-equal to 1.5A ( ie. 1500mA )

If you don’t have a USB supply and micro USB lead that suits, we stock an Official Raspberry Pi Power Supply rated to 2.5A, which already has the correct usb connector to plug directly into your Pi.

Michael. thanks heaps. all fixed…
i was getting my Volts and my Amps mixed up, haha.
All up and running now.
thanks so much.


Fantastic to hear, Frank. Best of luck with your projects!