Core Electronics Forum

Raspberry pi Zero W constantly freezes

Hello,
I received my Raspberry Pi Zero W a few weeks ago and unfortunately have had issues with it from day 1. It constantly freezes for no apparent reason, is this a known issue?
I have installed the latest, full version of Raspbian (by etch, because the pi always froze on install from NOOBS) and am using an official RPi power supply.
I am using a 16GB Sandisk Ultra, class 10 micro SD, HDMI adaptor and a Logitech unifying receiver for the mouse and keyboard.
Is it possible this is a software/compatibility issue? Or have I received a faulty Pi?
Any advice would be greatly appreciated, as I am new to the Raspberry Pi.

Hi Joseph,

This is a new one to me. Have you tried a different power supply or SD card? Problems like this most often are caused by a corrupted SD image. Seeing as yours is fresh, that doesn’t seem too likely in this case though.

Thanks for the reply Stephen, I also have a Pi 3B+ and both the SD card and charger work no problems with that. I can try find another SD card and let you know how it works with the zero

What script/package is the RPiZW running - and are there any temperature / voltage warnings?

Hi Graham, sorry for the late reply. I haven’t had a lot of time to play around with the Pi and nail down exactly what freezes it, I’ll post an update in the next couple of days.
I didn’t have any issues on any particular script or package and only got a temperature warning once; when the Pi froze as I was trying to log into my Google account on chromium.
Other times it became unresponsive while installing packages such as BlueZ.

No worries. Perhaps try use Raspbian Lite for some tests, Raspberry Pi Zero isn’t well geared for the GUI overheads of the full version

Hi,
I have the same symptoms on a brand new Raspberry Pi 4 2Gb
(Fully updated OS/Desktop, no other libraries or software yet installed)
I also have a Logitech unifying receiver.
I’ve tried putting the receiver on a 1m USB extension without luck (this was suggested in a different forum).

Hi K,

How unusual, the Pi 4 even the 2GB version is usually quite reliable, I’ve got one set up running an OctoPrint server at the moment for a couple of printers I’ve set up with it and haven’t had any issues with limitations on the hardware like the previous issue in this thread was likely related to given that it was a Pi Zero running the GUI.

Reading up on the compatibility of a few different keyboards and compatibility with both the Pi and Raspbian (now Raspberry PI OS) from a few discussions online people have had about similar issues, it seems that there shouldn’t be an issue using one of the Logitech Unifying Receivers here.

When you say fully updated OS/Desktop, have you just recently reflashed the card with Raspberry Pi OS? Or have you run sudo apt-get update && sudo apt-get upgrade on an older version of the OS instead?

I’d suggest reflashing the card to ensure that there aren’t any problems there, and once you’ve done that, running lsusb from the command line if it’s possible to do so with a different keyboard and mouse combo just to ensure that you’re still able to see USB devices on each of the different ports of the Pi to ensure there aren’t any problems there with your hardware would be a quick and easy first port of call to diagnose the issue with it.

1 Like

Hi,

I reflashed the card with Raspberry Pi OS - Yes. Using the Raspberry Pi Imager
sudo apt-get update - Done sudo apt-get upgrade -Done

Both the original installation, then after the reimage, both keyboard and mouse stop receiving.
Removing and plugging the receiver back in the USB (any type) has no effect.
Rebooting the Pi enables the receiver to work again.
But after a maximum of 5 minutes (usually about 2), both keyboard and mouse stop working.

Hardwired mouse and keyboard work without issues.

USB ports work.

I had been using the same Logitech receiver (Keyboard and Mouse) on a Pi v2 as recently as 3 days ago, never had the same issue.

Regards,

1 Like