"Refuses to Connect" message from Pi 3B+

I’ve set up a Pi 3B+ to run headless and via wifi. I can access it via Putty from my PC (Windows 10) but when I try to get into it via my PC using the IP address and my browser, I get this “refuses to connect” message.

I want to use it as a simple NAS using a M.2 SSD I have. But obviously, if I can get into it, that’s not going to happen. I tried using OMV with the same result by the way.

Its got me baffled. The same message when I connect via ethernet through my NBN router. I can’t figure it out. an anyone offer me some tips/hints/words of wisdom?


code in a command prompt

ifconfig -r

ifconfig -v

it refreshes renews the connection

it should most likely need a new key activated

Cheers Brian. I may have given the impression I know more than I do about this.

DO you mean I shd Putty my way into the terminal window and enter a sudo ifconfig -v and/or sudo ifconfig -r command?

I did both a and the response on -r was (command not recognised) and on -v it pinged both the eth and wireless and showed there were packets sent and received on the wireless. But still no access via my beowser.


try this code

dhclient - r

dhclient -v

also it could be your permissions in your browser …i dont know what browser your using…

G’day Brian,
no luck. -r did nothing - no return or reaction. -v returned permission refused:
can’t create /var/lib/dhcp/dhclient.leases : Permission denied
RTNETLINK answers: Operation not permitted

I have used Edge, Firerox and Chrome - all with the same result.

I think it may be in the router.

Funny thing is I few days ago, I set up OMV and connected it via Ethernet to the router and was able to access the Pi via browser and conduct several operations definigi things. And then, it all went to hell.


1 Like

If you want to connect to a web server with a browser, then you need to actually need to have one running. OMV has a web based administration interface, set up as part of the OMV install. You can connect to a Pi running OMV because of this.

If you are running Raspian, there is no web server running, so you get “connection refused”.

If you want to use file sharing or media streaming, you need to install the appropriate software, configure it, and so on.

OMV has the web interface built in to do this, but you still need to configure the underlying services. e.g. FTP, samba, NFS.

Choice which way you want to go, then stick to it.

1 Like