Retroflag GPI - pi0 W unable to connect to wifi


I’m very very new to all of this.

I recently set up my Pi zero W in my retroflag GPI case.
I’ve installed the retropie image, installed the retroflag patch files, written my wpa_supplicant file etc…
I can get as far as switching it on & launching retropie.
It won’t connect to wifi no matter what I try, and I can’t access it using SSH/terminal (comes up with - “Could not resolve hostname retropie: nodename nor servname provided, or not known”) on my mac. I’ve connected a bluetooth keyboard, and tried to manually enter the password through the WIFI screen in the menu, still no luck.

Any tips or suggestions??

I’ve definitely already stretched way beyond the next to no skillset I had pre starting this journey haha.

HALP :slight_smile: !!!

You need some more networking skills before you get to address the RetroPie installation by name. :grin:

To start, you’ll need to use the IP address assigned by your DHCP server. This usually is running on your ISP supplied modem. How to get to it depends on your modem. Once you find the IP address, use that as the host you wish to connect to. Should be something like

1 Like

hmmm see this is the problem with asking for help and having such little knowledge… I even struggle to understand peoples helpful responses.

1 Like

Try this.

If you boot to terminal, type:

sudo raspi-config

Under network you can type in your exact wifi SID and password. On my Mac I simply roll the mouse over the wifi icon and I can see the name of my Wifi SID with a tick beside it. Make sure it’s character exact.

You will also need to find the wifi location and update it to Australia (AU). Can’t remember which menu it’s under, but you’ll find it in there.

Under interface options, turn on SSH.

Check your DHCP table on the router for an IP, device is typically called raspberry pi.

On my Mac I use terminal, type ssh pi@IP Address

Type Yes to the security warning.

It will ask you for the password (raspberry)
If that’s wrong you can change to in raspi-config menu.

If using a pc, most use putty.

This info should be fairly accurate, I’m not in front of my devices, just going off memory. If you get stuck there is heaps of YouTube videos to walk you through it.

1 Like

Hi Obtj,

Have you confirmed your WiFi interface is definitely working? I’d suggest installing the full Raspberry Pi OS on your SD card and connecting to your WiFi network through the GUI.

If you get a message that “No interface is found” please inspect the shiny chip on the Pi Zero W for signs of physical damage.

Support | Core Electronics

Thanks everyone for your advice!

I had done everything listed above and finally got it to work. It was setting my region that was the issue… I thought I had done that, but each time I would go back in, it hadn’t recognised that I had changed it to en-au.utf-8 utf-8 and kept reverting back to whatever its default was.

I just went back over all the steps and it worked.

Also lol was trying to connect via ssh with the retropie nickname rather than my IP address. Rookie error. BUTTTTT I am an absolute rookie at this and so so excited to learn more!!!

Thanks again!!!