RP2040 red flashing light and cant connect, tried everything

Hey, unfortunately I’ve run into connectivity problems before being able to even reach the point of bootloader mode or initialising communication with MU editor.

In a nutshell my RP2040 with attached musicmaker featherwing is stuck with a red, rapidly flashing LED. I cannot get windows 10 to see the device.

Here is exactly what I’ve done since first recieving the unit:

1 . RP2040 feather plugged in to laptop witrh usb C. Rainbow light swirls, plus fast blinking red LED port 13.

  1. Double tapping reset button temporarily stops flashing red light but it doesnt go into bootloader mode. Returns to rapid flashing when i stop pressing reset.

  2. Downloaded MU Editor, selected CircuitPython, device not recognized.

  3. Tried all other modes, device not recognized.

  4. Read online that blinking red light may mean power supply problem, so plugged laptop into power just in case there wasn’t enough voltage going out the USB. Still didn’t work.

  5. Being a total noob, I thought it might be necessary to attach the featherwing to hopefully get the micro USB to show up as a device on the computer.

  6. Soldered featherwing music maker to rp2040 using adapted male connectors with no female connector because I didnt know thats what you’re supposed to do, and we didnt have any, so now the boards are basically permanently fixed. But the soldering is not bad (photos attached below).

  7. Board still not recognised.

  8. Tested connection again on a whole different computer. Desktop this time. Not recognised by MU Editor or device manager.

  9. Tried to double tap for reset / bootloader bode many, many, many, many, many, times. It always returns to fast flashing red light.

  10. Tried on both computers, four different USB to USB-C cables, multiple USB slots and tested through a USB hub and the device is never recognised at all.

  11. Holding the reset button either pauses the rainbow where it is in the cycle, or turns it green sometimes, and turns off the red light temporarily. LED always returns to fast blinking red and rainbow continues when reset button is lifted.

  12. Bootloader button does nothing.

So we feel like we’ve tried everything as well as search through so many past forum results and help on google and cant find any further advice beyong resetting. The project is just dead before being able to do anything.

Photos of solder below. Please let us know what can be done.


Reading in between the lines, perhaps you’ve missed a key step from the Adafruit Feather RP2040 instructions:

hold down the BOOTSEL button while plugging it into USB (or pulling down the RUN/Reset pin to ground) and it will appear as a USB disk drive you can drag the firmware onto

With that in mind, the button needs to be pressed before plugging into USB. As the device enumerates, it will appear as a flash drive.

I hope that helps!


Hi Graham,
I can’t believe we didn’t try that earlier :sweat_smile:
It worked! thanks a million, so glad we can get this project underway
Bonnie and Jordan