I finally got around using the J-link edu module but I am struggling to use it. I’ve downloaded the latest drivers and upgraded its firmware through nRFgo studio but whilst I am trying to flash a board that contains the nRF52832, it doesn’t seem to detect the SoC. I’ve tried several changes of cables in case that was the issue but it still doesn’t seem to work. I am not an embedded expert but from what I have read online (refer to forum link) it seems VTref pin should have 3.3V supply to communicate properly with the target, which in this case I get roughly 0V. I just wanted to know if there is any information you may have of this occurring previously due to a faulty unit or what I am asking does not make sense?

Thanks for any help you can provide in advance.


1 Like

Hi Nicolas,

Just so that we might get some transferable workarounds, what was the target board in your case?


Hi Liam,

I am trying to program the RAK815 based on the tutorial on the link below.

I’ve wired everything up as per the RAK schematics and the instructions in the link to the header on the RAK 815.
So from
J-LINK <> RAK815
Pin 1 <> Pin 1
Pin 2 <> Pin 2
Pin 3 <> Pin 5
Pin 10 <> Pin 4
Pin 4 <> Pin 3

I am trying to program the softdevice on nRFgo studio and that is where I get stuck. Not sure if it might be some software version issue instead, but just wanted to make sure the J-link is not the issue.


Hi Nicolas,

It doesn’t seem like it, that connection matches the requirements. Have you been able to use the J-Link to be able to program any boards before? If you can flash an example sketch in order to test the functionality any error messages that occur should help us in identifying your issues.

Core Electronics | Support