Stuck in Bootloader mode, Circuitpy drive gone

I have Circuit Python V7.3.0 on my UM FeatherESP32S2 purchased from Core Electronics, and it worked perfectly.
Wanted the latest updated Circuit Python for my project, so I updated the Feather with Circuit Python V8.1.0 I know it was successful as I checked the file in Notebook to verify its version number. However, the CIRCUITPY drive did NOT reboot after flashing, no matter how many resets or power on resets I did.
Tried copying V8.1.0 again, copies fine but still no CP drive. Tried a newer version of CP V8.2.0 rc1, still no joy. I had run out of options so I updated the bootloader (update tinyuf2.uf2), completed that. Then copied V 8.1.0 uf2 file back onto the Feather. When in bootloader mode I checked the uf2 file and it is V 8.1.0 so the updated UF2 exists and V7.3.0 has been replaced.
Still the same as before, Circuitpy drive does not appear, actually nothing of the Feather appears anymore, unless I go into bootloader mode again.
Would appreciate some assistance getting the Circuitpy drive back.


Hi Jeff,

I’d recommend checking out some guides for ESP tool and using the wipe function to clear all of the flash.
Should work perfectly after!

1 Like

Hi Jeff, welcome back!

Sorry to hear it’s giving you trouble!

To add to Liam’s response, it seems there are decent tutorials on wiping the flash around:

Did you find that did anything to fix this issue? Does going back to 7.3.0 fix it, or is it something deeper than that?

Keen to hear how you’ve been getting on :slight_smile:

1 Like

Hi James and Liam,
In summary, zero success.
Tried to load the esptool as per RNT site tutorial.

  1. Python 3.11.4 installed on PC :white_check_mark:
  2. Setup tools and pip also avaiable on PC :white_check_mark:
  3. yet when I try to run pip install esptool in Terminal I only get errors, such as “pip” is not recognised, totally confusing.

Basically not able to use the esptool as I cannot get passed installing it. Copy of Terminal text in jpg attached.


1 Like

Hi Jeff,

If you use the Mu editor are you able to get into the board’s shell?

Also wanted to confirm that you’ve followed the instructions on the FeatherS2 page for reflashing the bootloader and CircuitPython versions: FeatherS2 - The Pro ESP32S2 development board in the Feather format.

When flashing the uF2 should be ‘consumed’ and the new folders and file structure appear

Note: to use pip you’ll need to install python, check out this guide on installing packages: Installing Python Packages - Tutorial Australia


1 Like