Tvheadend, Pi TV Hat not DVB-T Network

Hello everyone, I was hoping to get some help with the TV Hat. It can not seem to find the DVB-T Network, as stated in the documentation.

I have connected the TV Hat to my Raspberry Pi 4 and the light comes on, installed a fresh Raspberry Pi OS (tried both 32 and 64 bit OS).

I have installed Tvheadend and ran it through a web browser. When it comes to selecting the network I can only see IPTV Automatic network.

I have also tried enabling both the SPI and I2C interfaces and this makes no difference.


Hi James, Welcome to the forum!

I know this seems obvious, but have you run through the steps in the official Pi guide?

It’s also worth mentioning that the latest version of Pi OS, Bullseye, broke a few things, one of which could be tvheadend. It may be worth installing the version before, Buster, to make sure that’s not the case.

Keen to get to the bottom of this with you!

Hi James,

Thanks so much for getting back to me. Yes, I have following the attached guide. I also just took a few moments now to try Pi OS Buster.

Following the guide, I get to the below stage.

It should have DVB-T, according to the documentation, but it only has IPTV as an option. I also tried configuring DVB-T manually, but it doesn’t work.


Hmm, the guide is suggesting something should appear as “Network 2” :thinking:

Could you share a photo of how you’ve got things connected physically? reveals this HAT uses SPI, but not I2C, though you should be able to run an i2c scan with
sudo apt-get install i2c-tools
i2cdetect -y 1
to detect whether the on-board EEPROM is getting power and happy.

Fingers crossed we can get this solved!

Hi James, thanks again for your reply.

You are correct, it should show a “Network 2” and I have see that in other tests.

Here are some photos of the setup. All pretty basic (I had it screwed down prior to the photos made no difference to the tests):

I ran the i2cdetect -y 1 with the TV Hat and got this result:

I removed the TV Hat and put on a Sense Hat, which I have previously had working. I ran i2cdetect -y 1 on the Sense Hat and got this result:

I even changed the header to see if that was the problem, however there is no difference. Since the Sense Hat is working with a very similar setup, could it be that the TV Hat is faulty?


1 Like