Unable to connect Pi Zero to my router

Hi there. I’m having trouble connecting my RPi Zero W to my router. I’m using the latest version of Raspbian, and have gone through the setup. I was unable to connect to my wifi router, but when I tried connecting to my phone as a hotspot, it worked straight away. I suspect that there could be a setting in my router that is preventing me from connecting to it… I have tried playing with some of the wlan settings, but no luck. Any suggestions?

Hi Joseph,

What happens if you put the RPi Zero right next to the router and try and connect?

Tried that. Still no luck. I’m trying to connect via GUI, and I can see a nice strong signal from my router, just can’t connect.

Well this is weird… I was just having a look around in the router settings page, and un-hid the password field, and discovered that the password in there is different to the one that’s on the sticker on the back. The one on the sticker is the one I use to connect everything else (combination of upper a and lowercase letters and numbers). The one in the router settings page is just numbers. I put the just numbers one into the Pi, and hey presto! I’m connected!