Pi Zero W wifi issue

I recently bought a Pi Zero W and have spent the weekend trying to get it to connect to my wifi network with no luck. I initially used the tutorial at https://core-electronics.com.au/tutorials/raspberry-pi-zerow-headless-wifi-setup.html except I downloaded the newest Raspberry Pi OS (32 bit) lite version.
I didn’t buy a Micro USB OTG Host Cable because the headless setup video looked quite simple.

Everything went fine with setup and it seemed to boot properly but when I tried to connect with it through Putty I get the “host does not exist” error. Also when logging into my router I noticed the pi isn’t listed under connected clients (it’s a TP-Link Archer VR900 if that helps). I tried the troubleshooting section too but wasn’t able to get it to work. Are there any settings I need to change in my router to allow my pi to connect?

I’ve now tried multiple other tutorials and formats of the wpa_supplicant.conf file and have tried creating it in Notepad++ to be able to save it as Unix EOL but it just doesn’t seem to connect. The pi is sitting right beside the router so range shouldn’t be the issue.

If anyone has any suggestions or thoughts, I’d appreciate it because I’m getting a bit frustrated and already spent quite a few hours trying to set it up.

First time I set up headless it did not work. Cannot remember why. But, anytime I cannot get it to work , connecting a monitor and keyboard usually helps.
Even if you just connect a monitor to the HDMI port it might show you what is happening.

If the Pi is not showing up in the router then its the authentication process might not be working.

Most home networks do not have local DNS setup, so you cannot use the host name of the Pi, you need the IP address assigned by the router. Static addresses make this easier, as it does not change each time it expires.

Best of luck.

1 Like

Hey Brendan,

It’s worth trying the full version of Raspberry pi os. This walks you through all the setup for Wifi. If that doesn’t work then you might have a hardware issue.

Definitely worth grabbing a micro usb otg cable and a mini hdmi adapter. Troubleshooting networking problems externally can be really frustrating - so much easier to do it locally on the machine.


Thank you both for your suggestions. I ended up flashing the full version of Raspberry pi OS and had no problems connecting to my Wifi. I appreciate your help.


Good to hear you found a workaround to the problem.
Headless is a very useful technique for single board computers, especially the Pi Zero that would commonly be run headless. My notes for headless wifi config are below. Be especially mindful of the country code requirement in wpa_supplicant. It is a required item. Now that you have a console, I suggest practising setting up wifi headless and use the console to see where the issues are.

Configure Wi-Fi
Create a new empty file that will hold network info:
touch /Volumes/boot/wpa_supplicant.conf
Edit the file that you just created and paste this into it (adjusting for the name of your country code, network name and network password):

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


This file will be deleted after first boot.