USB to TTL UART RS232 Serial Converter Module PL2303HX+AU Local Shipping (CE05185)

This is a placeholder topic for “USB to TTL UART RS232 Serial Converter Module PL2303HX+AU Local Shipping” comments.

USB to TTL converters are an essential for prototyping - they provide a direct interface with the target device. This module connects to your computer USB port and there are 4 wires which connect with your target device. This model is the bare version of our enclosed model.

Read more

Does this support windows 10 / linux?

Are drivers needed for windows 10 / linux if it is supported?

Hi Geoff

You can get the Windows 10 Driver for the PL2303HX from the prolific website.
I can’t find anything on Linux support but someone probably has got it working.

Many Thanks Clinton.

This module is now obsolete. I recently purchased it and not only is it not compatible with windows 10 Prolific no longer supported by Prolific. In fact both USB-UART adaptors I purchased are obsolete. If it’s no longer supported not sure why it is still being sold on this site. Can you guys sell something that is not obsolete. I purchased this to program my Lopy only to discover this…

Hi Michael,

Sorry for the delay, looks like we missed your post. Thanks for letting us know! I’m going to grab a couple from stock and test it out. Will update this thread once I have more info.

Hi Michael,

I’ve just tested this product out on 2 different WIndows 10 machines, and it does work fine. However, Prolific have broken support on Windows 10 in their latest driver.

To get it working, the steps I followed were:

  1. Download the driver linked in the product description, and install the Win 7 driver.
  2. Insert the USB Serial adapter.

If you did not install the driver from the downloads page you can get it working by performing the following steps:

  1. Insert the USB serial converter in your machine
  2. Open your Device Manager, and uninstall the driver installed by windows (select to delete the installation files).
  3. Install the driver linked in the product description.
  4. Remove and reinsert the USB->Serial converter

Hi Oliver,
I don’t see any driver linked in the product description. Could you please help?
Just bought one yesterday and have problem with windows 10 driver.

Hi Michael,

Here’s the direct link:

Enjoy your weekend! :slight_smile:


Hmmm it was there and I missed it… Thanks!
By the way it works even for my rs_prerelease windows 10 version.


I must be doing something wrong, the serial converter is recognized when i plug it in to my computer and I can see it in device manager. I am only using the ground, tx and rx as the device has its own power. The serial converter has a single red led which is on. When I open putty it will connect to the com port but there is no data from the device the serial converter is connected too even after hitting the enter key. I have tried the serial converter on a Win10 and Win7 device, I have built another cable to connect to target device, I have swapped the tx and rx just in case I have them backwards. I have tried a known working target device. running 115200 , 8 bit , 1 stop bit , no parity , flow control is Xon Xoff which works for others.

You should set up the serial port in loopback mode to confirm that the driver is working.

Have you tried sending XON in order to start the transmission? What is the device you are connecting to, and what response are you expecting for a CR?

Do you have another serial device that you can test the converter with?

1 Like

thanks Jeoff, the loopback worked fine. Im connecting to a drone that has a Linux based OS on it. When I her the enter key I am expecting to see a login screen. The loopback proves everything up to the connect on the converter so I will look future down the line for an issue.

1 Like

Hi Jeff,

That’s a great to-the-point video and they even managed to include a bit of humour!
Thanks for sharing that, I’m saving that link for later, no doubt serial loopback tests will come up again soon.

thanks Jeoff, I switched over to a CP2102 converter and its working fine. In sure the 2303 will work if I go back to it. I made a couple of changes at the drone hardware end as well.