😞⚠️ What is this weird error message? (Adafruit soundboard) [Resolved]

Hi all,

I hope you had a lovely weekend :sun_with_face:

I’d love your help!

I’m trying to run my Adafruit soundboard using the serial monitor (following this Adafruit tutorial step by step: Serial Audio Control | Adafruit Audio FX Sound Board | Adafruit Learning System)

The problem:
Despite following this Adafruit tutorial, I get this error:

The code I used is the one provided in the Adafruit tutorial, I just copy & pasted this code without changing anything. Here it is: Adafruit_Soundboard_library/menucommands.ino at master · adafruit/Adafruit_Soundboard_library · GitHub

What I’ve tried to do to fix this problem:

  • I could successfully trigger audio using push button pins (by following this tutorial: Triggering Audio | Adafruit Audio FX Sound Board | Adafruit Learning System), but got the error message with the serial monitor (when connected to TX RX pins). Which leads me to believe that there must be something wrong with the RX TX pins.
  • I think it may be because I soldered my RX TX pins poorly, so may need to resolder them?

My wiring:

Note: Adafruit’s tutorial use a slightly different soundboard (their amplifier comes separately, whereas my soundboard contains the amplifier).

Here’s the diagram:

My question:

  • Does this error message indicate there’s something wrong with the TX and RX pins? So I need to maybe resolder these pins? Or is it another issue?

Thank you for your help! :smiley:

P.S. The reason why I think the cause of my board not working could be due to my soldering is because I’m not very good at soldering. In fact, I soldered for the first time yesterday, and half my soldering iron tip dissolved off. So now I also have half an iron tip left.

1 Like

The problem is in the communication between the PC and the Arduino, not between the Arduino and the sound board.

Check that you have the correct Board (UNO, judging from the image) and Port selected in the IDE Tools menu. I suspect the Board selection maybe wrong.


thanks jeff!

this is the port i’m using.

i also tried it on my windows laptop, and got the same error.

Screen Shot 2021-10-11 at 12.13.49 pm

do u know if there’s a way to test whether the tx and rx pins are working? thank you!


hey jeff!
so i tried running it on my arduino mega, and it worked.
so not sure what’s happening, but at least it’s working now :man_shrugging:


It appears from your image that the reason the Mega worked is because that was the board you had selected, and the reason the UNO did not work was that you hadn’t changed the Board selection to UNO.

Either that, or you posted a different image :slight_smile:


thanks jeff!

for the uno, i changed the port to uno.

and for mega, i changed it to mega.

all good now though. i think there may be something weird about my uno board.

1 Like

Hey Teena,

Just to double down on Jeff’s idea, I think you may have selected a Mega as the board type (not board port) when communciating with your UNO, which can give you these headaches!



hello james!

boink 🤦
good pick up!
i derped out and only looked at the port, not the other elements.

thank you for your help! :smiley:

i thought i bought a dud uno.