8bitdo sn30 keeps disconnecting and shutting down

I received an 8bitdo sn30 yesterday, and as the title suggests it won’t stop disconnecting. I’ve tried using it on RetroPie and windows 10. I’ve updated it to the newest firmware, and it hasn’t helped.

What should I do?

Edit: I’ve tested out my other 8bitdo sn30 and it also has the same issue, it may have something to do with the select button due to it happening the most often when I save.

Hey Josh,

I’m sure you’ve tried, but have you left it on charge for a good couple of hours?

Also, what mode are you configured for - both RetroPie and Windows would work best with different profiles, though I suspect you might be using the same for both (and quite possibly, the wrong one)?

The controller was fully charged, and by profiles do you mean dinput or xinput?

Here is the manual:


There is a section that shows different start-up modes for different devices.

And here are some notes about power saving:


Ok, I’ve tried each of those modes (even trying the ones printed on the back of the controller that wasn’t shown in the link), and sadly it hasn’t helped with the pi. On windows it seems to be fine though, I’ll try out some other controllers on the pi to see if that’s the issue because it doesn’t seem to be accepting my xbone controller.

Edit: looks like it stays connected to my pc, but doesn’t want to react to my inputs on both modes specifically for PCs (dinput and xinput).

Hi Josh,

Thanks for reporting back. Hit reply to your order confirmation email and link-in this forum topic. We’ll see what we can do.