Adafruit RGB Matrix HAT to P10-s4-3535 panels

Hello everyone, I’ll get straight to it, I have 3x ‘P10-s4-3535’ matrix in series. These are 32x16 pixel panels with a HUB75 header on each end. See attached pic.[Uploading: P10-s4-3535.jpg…]

They appear to use 4bit multiplexing address, ABCD and I’ve read they might use a ‘Z’ stripe connection configuration.

I’m using software, I’ve tried heaps of different configuration command line options but each time I execute the command the display shows a rough block of pixels (always the same pixels, position and colour) and interestingly enough the Rpi pops up with the shutdown or logout dialog box and terminal cursor blinking goes fast and erratic the instant you press enter. I have to reboot the pi each time.

./demo --led-gpio-mapping=adafruit-hat --led-rows=16 --led-cols=32 --led-chain=3 --led-multiplexing=9 --led-addr-type=2 -D0

I have a HD-D15 driver board that came with the panels which does drive them, but the software and interface doesn’t work with my industrial PLC, which is why I need the display. This driver board uses HDplayer software (Windows based) which doesn’t allow comms between it and a PLC. Extra into, the backup settings file for this driver says something about being 32x8 pixels not 16 D15 with P10 display (11.2 KB), see row 8 of this xml file.

I tried the pin4 to pin18 jumper and selected PWM, this didn’t fix anything either.

I’m not familiar with these panels or HUB75 electrical timing or sequences so I don’t even know what I’m meant to be looking for if I was to connect my scope to the I/O lines.

Any help or suggestions would be appreciated, thanks in advance.

What power supply/supplies are you using? (Voltage and amperage)

How are they connected?

The Pi will reboot if it doesn’t get enough power and “brown out” occurs. Suddenly turning on several hundred LEDs places quite a load on a power supply.

Hi Robin57159, thanks for your reply.

The power supply that is supplying the led matrix is a 4.5volt 40amp switchmode PSU:

This power supply connects directly to each panel using the three white plugs via the red&black cables. This was the supply that came with the three panels, along with its HD-D15 driver board, which works [but i don’t like it :)]

The raspberry Pi is being powered from a 5v 3amp USB power supply.

The Adafruit hat was running from a 5v 1amp supply via the DC input socket on-board (note: i dont know if this supply has to be the same as led matrix supply or not, i didnt try that but I can)

Just to be clear, the pi doesnt reboot or brownout. it sporadically pops up with a dialog box asking me if i would like to logout, which is weird. I can click cancel and return to my command terminal, but from that point forward commands i type dont make any changes to the led matrix.

Thanks again.

Update on this, matrix’s still arnt working but the weird pi stuff is fixed. It was the HUB75 pcb header, it was soldered on backwards (yes I know, whoops)
Still trying to find the correct matrix wiring pattern to make them work.
Thanks again,