Can’t connect Makeblock Mbot for Scratch X - Chromebook

My son and I are trying to get the Mbot to work with the Makeblock Mbot for Scratch X app on his Chromebook. I have watched a lot of videos and followed the directions. We are able to pair the mBot with the Chromebook but on launching the App we get stuck on the following screen. It seems to be a common issue. Can anyone assist?

Hi Jason!

It looks like MakeBlock Mbot for Scratch X is an app that is no longer supported, and I can’t say this for sure, but it looks like its made by an unaffiliated company.

The app that you should use to interface with the Makeblock Mbot is called “MakeBlock”

Or if your on a PC you can find the software here:

I was only able to find a little bit of help with the Scratch X app, and it looks like recent updates removed the functionality of the the workaround that this person found:
"There is a trick to connecting the mbots.
1.Make sure you have google chrome open
2. Open your bluetooth preferences
3.Turn on your mbot
4. Two new options should show up. One will be Makeblock_LE followed by an IP address DO NOT click that one! The second will be Phone followed by an IP address, this will switch to MakeBlock after a moment, pick that one. (I went through this step with all 20 of our Mbots before hand and wrote the last four characters of the IP address on the corresponding mbot to make them easier for the students to connect to)
5. You will get a popup with a code asking you to confirm that it is the same number on your connected device, just accept it. Sometimes it will say it failed but usually it is still connected.
6. Then open this Chrome extension and pick the Makebot with the same address as the one you connected to before.
7. Click “connect” next to it then once it switches to “disconnect” go to the bottom then open scratch X

So these instructions have worked for pairing our mbots 100% of the time; however, as of today when I open ScratchX the extension isn’t there."

I hope that helps! Let me know if it doesn’t work out and I’ll help however I can!

Hi Stephen

Thanks so much for your help. I will give this a try when I get home. I will let you know how I go.



1 Like

Hi Stephen

I have tried this a few times and given up. It seems that the app from GooglePlay wont work on a ChromeBook. The only Chrome Web Store Apps available are “Makeblock mBot for Scratch X”, “MBlock” or “Mlink”

I am wondering whether anyone with an mBot may have gotten this to work

Hi Jason,

Here is a new link directly to the Makeblock software for Chromebook:

Thanks Steven for the link.


1 Like