Can't open device "/dev/ttyACM0": Input/output error

just got an arduino beginners kit, followed the instructions to get the blink program working but i keep getting “can’t open device “/dev/ttyACM0”: Input/output error”

i added myself to the dialout group and logged out and in. still nothing. tried the online IDE but get the same error message.
googled the issue but its all about what ive already done
any ideas?
ubuntu 20.10


Hey Bluewater :slight_smile:

Which kit are you using? Some variants of the Uno use a different USB-Serial converter, though most of them have driver support built into the linux kernel so it shouldn’t be an issue.

Here’s something I found with a quick google which might help:

This stack-exchange post gives the same solution, so fingers crossed!


DFRobot kit
yep tried that but it didnt work

this is the kit

it works fine on windows so no problems with the hardware, just cant get it to open that port

Arduino: 1.8.15 (Linux), Board: "Arduino Uno"
avrdude: ser_open(): can't open device "/dev/ttyACM0": Input/output error
1 Like

are u using arduino sketch you must select the correct port in the settings

pls read here

EDIT:: also a handy book would be getting started with arduino sketch from jay car very helpful for beginners …

1 Like

yes there is only one port to select, it works on my other ubuntu machine and windows, just not this one. i think it might be a problem with the kernel

Definitely very odd then. Are you sure you’re trying to communicate with your Arduino and not another device?

With your Arduino plugged in, try running ‘lsusb’ from a terminal - this should list all usb devices currently connected.

1 Like

yep its connected

Bus 001 Device 015: ID 2341:0043 Arduino SA Uno R3 (CDC ACM)

i think im gonna have to reinstall the os, cause my hunch is something with the kernel, cause it works on other pcs


Hey Bluewater,

Welcome to the forums!

How are you going with the troubleshooting?
I had a look over at this forum discussion over on the Arduino forum: The Linux ttyACM0 drama - more details after a lot of experimenting - Installation & Troubleshooting - Arduino Forum

Apparently, it seems to be an issue with USB3.0, so switching USB ports might be an idea!



thanks for the replies. I have only usb 3 , i tried the uninstalling modemmanager idea from that thread but nothing.

tomorrow i will install ubuntu, currently running pop os. i know its not the sophisticated approach ,


“Turn it off and on again” works very often. It can be a bit of a nuclear option when it comes to an OS, but it does get the job done more often than not! Worst case you should be able to eliminate OS level stuff and narrow it down to likely a hardware compatibility issue on that machine.


ok all good, re-installed ubuntu over the pop-os. my guess is some update i forced in the past messed up the kernel and only surfaced its head now. the risk with doing things this way is loosing all you data.

thanks all good now


Always good to setup the user data on a separate partition when installing a linux OS - makes it much easier to do clean installs :ok_hand:

1 Like