Firmware not found :(

Hi, hope you’re well :sunny:

Raspberry Pi newbie here!

I tried booting up my Raspberry pi, but this error appeared:

I used the Raspberry Pi Imager to write the SD card with the Operating System.

Is there any way I can fix this error?

Thank you.


Hello, you can try this discussion regarding this particular error: Firmware not found · Issue #1655 · raspberrypi/firmware · GitHub


Hey Teena,

Welcome back!!

Your problem might be as simple as a bad flash or a faulty microSD, if you try and reflash a brand new card are you able to boot?
Have you been able to use this Pi in the past?

Keen to see what you make! How has your thanking robot been?


hello liam!!! it’s great to see you again!!! :smiley: :smiley: :smiley: :smiley:

the sd card + pi are all brand new! i messaged the supplier to see whether it’s a common error. hopefully they get back!

i’m so happy you remembered my thanking robot!!! she’s been great, she’s now living out her retirement years in my loungeroom. whilst she was still working, she sung her robotic heart out to everyone.

hope you’re doing well!

1 Like

thank you!
i had a look at this post before posting here, and it looks like the issue is still unresolved.
so hoping for more guidance!

1 Like

‘Firmware not found’ has nothing to do with the SD card.
It is the EEPROM on the board which starts the boot from the SD card.

I managed to kill a Pi 4B and got this message, it was panic stations for me.
Reloading the firmware as suggested by a tutorial on how to get the Pi to boot from a USB Drive is what got me into trouble. Raspberry Pi don’t have this adequately documented as far as I can tell.

I followed the Fastoe process and was able to get the Pi 4B back and working.
The link provided in their page is to an old version of firmware.
I would try the latest from the Github link.



Thank you so much James!!
It looks like from what you said that you were able to revive your Pi by using the Fastoe process, right?
My worry is that I killed my Pi permanently.

I’m curious as to why booting from a USB drive would kill the Pi. Is it because something shortcircuited?


Yes I was worried I had killed the Pi 4B too.
As it was not booting off an SD there was no reason not to try something.

The problem was the tutorial to setup USB boot said to update the Firmware. I followed the steps and it looked like it was ok but when I tried to boot the Pi again nothing happened. It was more complex as I was accessing the Pi via SSH. I connected a HMDI display and the ‘Firmware not found’ message appeared just like your screen shot.

The Fastoe process creates a SD that will restore the Firmware, that is all it does. I used an old 2G Phone SD and have kept it in case I ever need it again.

The Pi 4B is now working nicely as a USB Boot. I followed a different tutorial that did not involve changing the Firmware. I am vey hesitant to do anything with the Firmware given the experience I went through.

BTW Do NOT update the Firmware if your Pi is booting ok. It is only when it wont boot, you have no other option. Its like the BIOS in a PC, there is no reason to change it if it works.

This process may work for you, it may not, I wish you all the best.



Thanks for jumping in Jim!
That link and process ought to help a ton of Makers!

We’re keen to see if that fixes your issue Tina! Given its still outputting something via HDMI, it should be recoverable/



Thank you James!

I followed your advice & here were my steps:

  1. Downloaded most recent EEPROM from the Github link you esnt
  2. Followed Fastoe steps
  3. Connect Pi to monitor and Green screen appears! (Yay)
  4. Used Raspberry Pi Imager to write new Operating System (Tried both Raspberry Pi OS 32-bit and Raspberry Pi OS 32-bit full) on the SD card
  5. Connected up to monitor, Firmware not found screen still appears :frowning:

Is there a chance I got a faulty Pi?
I bought it from

Thank you again for your help!


Thank you Liam! Fingers crossed :crossed_fingers:


Fixed it!

Not sure what happened

I redid the Fastoe process 2-3 more times.

But it now boots!!!

I’m so confused.

Thank you for your help!!


If I remember right, mine did not work the first time either. Glad you got it working.
Its a good reason not to mess with the firmware even if the tutorial says you should.

Just a few things to ask your self.

Was it brand new, like never been used ?
If it was then the retailer should replace it.

If it was working, what were you getting it to do when it stopped working ?
In my case it was completely my fault, the board had worked perfectly up to then.

Document it so you know what to do if it happens again.

Anyway, happy for you