I can't get my Raspberry Pi to boot

Hey! I’m trying to get my new Raspberry Pi 4 setup to run a camera and Lightburn Bridge for my CO2 laser but I can’t get it to boot. I’ve formatted the new SD card and written the Raspbeery Pi OS 32bit to it, put the card in the Pi and powered it up, then it begins to work with the screen coming on, some green light flashing for a minute or two, the Raspberry Pi logo pops up on the screen for a few seconds then everything goes to black except the red power LED. I have tried waiting up to around 20 minutes, reformatting the SD card, using a different SD card, updating the Bootloader, a couple of different OS’s and still the same thing keeps happening. Any tips would be much appreciated!

Hey Nick,
Welcome to the forums!

That’s no good, when you start it up without an SD card in the device, are you still seeing the normal bootloader screen?
Are you using the Raspberry Pi Official Power Supply to power the device or an alternate power source? The Pi 4 has a slightly different power requirement than normal USB devices can provide.