Pi 4B - Not booting

Worked well since birth until last week. Now won’t boot from either SD or SSD
Red & Green LED’s steady
Loaded fresh EEPROM image just in case, followed all advice that I could find on the net and have come to the conclusion it’s bricked.
Have come over to here for confirmation so I don’t waste anymore valuable time chasing my tail around trying to solve the unsolvable.
Can anyone add anything before I start a RMA?


Hi Mike,

We have some standard troubleshooting steps you can run through to get the obvious stuff out of the way:

  • If Pi 4 or 400 - Ensure that HDMI is connected before the power and is connected to HDMI0 (the one on the left when facing the HDMI ports).
  • If Pi 4 or 400 - Try removing the SD card and powering on the Pi with HDMI connected to HDMI0. If you get video output and a bootloader screen there is a high probability the issue is with the SD card or software, not the Pi itself.
  • If using your own uSD (not a preloaded NOOBS from us), we recommend BalenaEtcher or Raspberry Pi Imager to write the freshly downloaded image to your USD (this fixes most boot issues, due to incorrect formatting methods)
  • If using your own uSD, you will need to use the newest version of Noobs or Raspbian for support of new board variants.
  • If Pi 4 or 400 - Check that the bootloader is correct with the recovery steps.
  • Have a look over this thread that has a lot of advice on boot issues.
  • Check that the SD card has not been damaged by a drop or mishandling (uSD should be removed when installing Pi into a case to avoid snapping the uSD).
  • Ensure you are using a power supply that can provide 5.1V (not just 5 Volts) at a minimum of 2 Amps
  • Check the HDMI cable connectors for damage. Shine a light (phone torch would suffice) into the connectors and check for dislodged/damaged pins.
  • Check the Power Connector (both on the Pi and on the lead) in the same way, inspecting for dislodged/damaged pins.

As all RPi boards are electrically tested post-manufacture, in the majority of use cases we find the uSD is at fault (we have replacements here if you don’t have one handy).

If that doesn’t work, we can look into it further!

1 Like

Have done all of the above before starting the thread.
FYI all Rpi’s we run are headless using 2.4A PS. This is the only Pi4 we have used, not a good experience as it’s used for prototyping and product testing. Had big plans for the Pi4 but it appears to be unreliable and not fit for purpose which is odd as it’s run perfectly well since purchase until last week.
This now becomes a time management issue, our time is better spent not having to fix problems that shouldn’t be there, traffic on the net seems to indicate that it is a known issue - yet there is no known fix other than returning the unit.
Happy to send it to you for your evaluation prior to binning it.

1 Like

Hi Mike,

On the rare occasion products can be faulty, that’s life. But happy to help; reply to your order confirmation email with a link to this topic and we’ll get this sorted out.

1 Like

Hi Graham,
Thanks for the prompt reply, lets take this off group (it shouldn’t have been here in the first place but I was directed here), Please PM or email me and we can continue.

Hi Mike,

DIY Electronics is fraught with knowledge hurdles and having a quick chat beforehand is certainly worth it. Most issues are resolved after some light collaboration.

So please do feel free to post questions, we are more than happy to assist.

And regarding your RPI, please reply to your order confirmation email with a link to this forum topic.

1 Like

Had a Pi 4 recently that looked like it was bricked. I had loaded a new EEPROM image because that is what the instruction said to do. There was no display, nothing, cannot remember what the lights were doing.

Found a site saying try to restore the bootloader to factory defaults. You can do this with the official Pi imager. The following screens show what I did. I loaded it to an old 2G SD card, it worked to get the Pi going again. Now I am very wary of changing the EEPROM, if ever.

Click choose OS

Scroll to Misc utility images and click it

Click Bootloader Restore the factory default

Click SD Card Boot

Then select whatever SD card you have loader and click Write.

Boot from the SD card and let it do its stuff.
The Green LED will blink a steady pattern when finished, the HDMI should be a green colour if it is connected. Does not take long but they said to leave for at least 10 seconds.

Remove the SD card and reboot, you should see some messages from the Pi on the HDMI trying to find a boot device. After that boot from an OS SD card and it should work. Did for me, much to my relief.
This may or may not work for you, but worth a try.


Hi Jim,
Thanks for the reply.
Unfortunately I have done all of that before posting and just to be on the safe side with different SD Cards.
It’s the Pi and I’m waiting on further instructions from Graham.

1 Like