How to make a Raspberry Pi NAS - A NAS-Berry that Runs Open Media Vault

I have just shared content in Guides > Raspberry-Pi " How to make a Raspberry Pi NAS - A NAS-Berry that Runs Open Media Vault"

Read more

1 Like

Can you elaborate on the message about an installed desktop environment?
I - think - I did not install deliberately. I use the Pi in a headless situation.
Is also vnc an issue?
Why is desktop an issue?



Hi, I installed the backup plugin but cannot see where I get to choose when to run the jobs.

Hello. Just to test, I ran it on my Rpi 3.
Image utility kept hitting a disk error while writing uSD.
So I wrote the PiOs lite 64 with Rufus…
Everything works fine, but the third line (your wget) bleats :

Omvinstall : only debian 10 (Buster) and 11 (Bullseye) are supported, exiting …

1 Like

@Kris131767 Some time ago I setup Open Media Vault on a Rpi 3, and it worked nicely till it didn’t.
Think there had been a update to Open Media Vault, as I could not get it to install again.
Ended up using Samba and MiniDLNA to stream my videos.

The guide uses a Rpi 4 and Lite Version install of the OS via the Raspberry Pi Imager installer.
The install script will complain if a Desktop Environment is installed.

This is most likely because Open Media Vault is not compatible with the new version of Pi OS. Debian version: 12 (bookworm). Scroll down the download image web page to the legacy area and download the legacy version.



RMIT Classification: Trusted

Thanks James.

I realised that indeed I downloaded the wrong version (bookworm)
I couldn’t use Rpi imager for some reason.

I downloaded 11 and then it was ok, however it fails install of OMV.
It always throws an error because I think SSHD doesn’t get installed.

It seems the new version of Rpi imager wants you to explicitly enable SSHD.

I need to try again but will take your advice of getting an Rpi 4. I was hoping to try it first with an existing rpi3 to see if it’s worth getting a pi 4.

Thanks, 73.


Sounds like you have gone through some of the things I experienced with OMV.
In the end a dedicated NAS seemed a better option to me.
(I have a Synology NAS which just works every time I want to use it)

Thought my problems with OMV may have just been me, maybe not, given what you have experienced.

It may work with a Rpi 4, but then again maybe not. I based that on the guide from Tim using a Rpi 4.
In any case I cannot trust the integrity of a OMV NAS based on my experience. Rpi OS & OMV updates should not adversely affect what I have stored on the NAS.

All the best

PS others may have had a better experience than me.


RMIT Classification: Trusted

After explicitly enabling SSHD in Imager, and ticking to “apply custom settings”, OMV installs with much noise.
Took ages, must be the lower CPU munch on the Rpi 3.

Got it all going and SMB runs fine, but I can’t write to the share in the NTFS folder (yet).

At least, it runs now, thanks James.

1 Like

@Kris131767 Good to hear.
If I remember right, the permissions to write did not work at first when I had it running.
There was a process to go through to get it all working correctly.

Comparing OMV with a Synology, a WD and a Seagate NAS, all of which I have used to varying degrees. OMV was the most complex to setup and then when it stopped working after an upgrade and would not install again, I was pretty pissed with it.

Maybe I should give it another try with a Rpi 5 (when I can get one).

Glad you can at least load it.

RMIT Classification: Trusted

I concur James,

I’ll probably end up getting a decent Synology NAS.
I’m a bit new to NAS world, my wife would like to have Plex running and I’m not sure where to start :slight_smile:
Lots of conflicting opinions and “consensus”…

I wanted to see what it was like with an Rpi and it seems much ado about not much, headaches I don’t need.

Tnx, 73.

1 Like

RMIT Classification: Trusted

Hey James,

Thought it worth an update.
Looked at OMV setup again and noticed that.a few things have changed slightly with OMV since the article.
Mainly, I had to explicitly add my NTFS shared folder at Services → SMB/CIFS → Shares :
(I can’t see this step in the article, just before optionally adding RAID)
and save that, everything came good then.

Considering the measly RPi 3 I’m running it on, I’m getting between 11 and 12 MB/s, which I’m happy with for now- considering an old Iomedia NAS thing I was using barely does 4 MB/s.

So, there it is, wonder how long before an update will break it :slight_smile:
Oh, I installed File Manager on my Android and now I can finally access the NAS from my Galaxy…

B rgds

Glad to hear its working good.
Rpi is an amazing product for what it can do and its low cost, relatively.