LibreElec Raspberry Pi 4 blank screen & other issues


I’m having trouble with a LibreElec installation on a Raspberry Pi 4. The first issue is that for some reason when I reboot the Pi once it does its startup checks and shows the LibreElec screen it goes blank. If I remove the HDMI cable and re-insert it, it shows the Kodi interface. I have looked online for possible solutions, which mention editing the config.txt file. I have set this up multiple times and have never encountered this problem before.

On top of this there is no CEC connectivity as well as no audio. Could this all be related?’

I have solved an issue where it wasn’t loading the SQL database, by checking the “wait for network” option. Although, I now have a problem when it boots is has failure that says -

‘[FAILED] Failed to start Wait on Network.’

when I get a status on the kodi-waitonnetwork.service this is the result:

● kodi-waitonnetwork.service - Wait on network
   Loaded: loaded (/usr/lib/systemd/system/kodi-waitonnetwork.service; disabled;
   Active: failed (Result: exit-code) since Fri 2019-04-12 02:28:48 AEST; 1 year
  Process: 352 ExecStartPre=/bin/sh -c echo "waiting on Network to come online .
  Process: 357 ExecStart=/usr/sbin/connmand-wait-online --timeout=${WAIT_NETWORK
 Main PID: 357 (code=exited, status=110)

Apr 12 02:28:38 LibreELEC-4K systemd[1]: Starting Wait on network...
Apr 12 02:28:48 LibreELEC-4K systemd[1]: kodi-waitonnetwork.service: Main proces
Apr 12 02:28:48 LibreELEC-4K systemd[1]: kodi-waitonnetwork.service: Failed with
Apr 12 02:28:48 LibreELEC-4K systemd[1]: Failed to start Wait on network.

I am now getting this error even if I uncheck the ‘wait on network’ option,


read the raspberry wiki pages concerning your audio and video problems depending on what operating system you are using you may need to set some parameters into one of the boot files…networking is not my forte…but you should be able to get your crc/video/and audio fixed via code…try another screen as well i have seen this issue so many times…check cable as well. all…cases are not always the same…

1 Like

Hi Anthony,

I have tried running LibreElec on my own pi and I couldn’t replicate the issue. What I did find however is that there is a good 20-second wait on boot where there is no signal to the monitor (or tv). If not, I would recommend reflashing the pi using the raspberry pi imager found here: Hope this helps!

Hi Anthony24983,

Where you able to resolve this? I don’t have the trouble your mentioning with my instance of rpi4 and libreelec.

Additionally, what is the libreelec version you are running? Is it v9.2.5?

Changes since 9.2.4:

  * firmware fix for RPi4 (blank screen at start)

Have you tried another HDMI port on your TV? That is not CEC enabled (just to try)?

Hope this helps.

here is a rpi wiki page have a read through this …also only have the rpi connected to the screen if it is a t.v set…

also if you are willing pls list make and model of screen i will look up its specs…
concerning what you should have in your config.txt file…!!!..

if your using both ports at the same time this could be an issue as they have different frame rates when used in conjunction…from mem i think one is capable of max 60 fps or both 30/60 or 30/30 when used together…