LoPy 4.0 connection w/ Atom+PyMakr (or VSCode+PyMakr) or or (PyMakr IDE)


I’m having trouble reliably connecting via an IDE to my LoPy device via the remote terminal via USB serial using REPL console.

I recall at the TTN Maker group last week that Graham mentioned he’d experienced an upgrade incompatibility issue whilst running the TTN workshop a few days prior.

I just received my LoPy 4.0 yesterday + LoRa 915 aerial + Pycom Expansion board V3.0

I have so far the following setups (all in Win10 64bit):
[1] Atom IDE 1.32.0 x64 + PyMakr 1.4.4
[2] VSCode IDE 1.28.2 + PyMakr 1.0.3
[3] PyMakr IDE
(I only have 3 just to try and get it working)


  1. I never have multiple IDE’s running simultaneously to lockup the USB serial port
  2. In case these IDE’s lock the USB serial port, and don’t release on exit, I have conducted clean PC reboots (just to be sure)
  3. I did strangely experience some success with the Atom IDE setup - if I disabled and then re-enabled the PyMakr extension. (but not consistently)
  4. [3] The ftdichip driver is the VCP
    2.2.18 x64 installed via the installer .exe https://www.ftdichip.com/Drivers/CDM/CDM21228_Setup.zip (Latest)

I haven’t yet tried any LoPy firmware updates or Expansion board v3.0 updates as I haven’t got that far into things yet.

I’m wondering if others are experiencing the same issues


I’m running…

After using the firmware upgrade tool (3 times) and selecting ‘stable’ release 1.18.0.r1
I now have things working,

ref: https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=win32&redirect=true

LoPy 4 Sigfox / LoRa radio’s are now set for Australian use

VSCode, Atom IDE’s working, but PyMakr IDE is not.


Isn’t it awful when it’s the update that causes problems. It’s always the last thing that I check!

Glad you got it worked out. I’ll be holding off my version at home now :slight_smile:


From what I understand, the Pymakr IDE is no longer maintained. Pymakr is now only available as a plugin for Atom and VSCode (which makes a lot of sense given how good those editors are).

Great to here you are back on track. For the benefit of future readers, following step 2 of the setup guide, you do need to update the firmware before use.

it’s not explained overly well in the Pycom docs, my take on this is Pycom hardware ships with OEM firmware that is often well-behind public-stable versions of other software (such as Pymakr 1.4.4 at the time of writing). After some quick updates, it’s all green lights.

PS - while updating firmware on LoPy4 is essential, updating the Expansion Board can be a pain (because of how USB devices enumerate). In my experience, the shipped version of the Expansion Board firmware works well-enough without the fuss of updating.

This is good to know Graham, thanks.

I updated my LoPy4 (thankfully didnt have nay problems), but have not yet updated the firmware on the expansion board (v3). I was only thinking about doing that just before reading this thread… I dont think I’ll bother now!


1 Like