PyCom LoPy failure

I received 2 LoPy and 2 expansion boards today.
I followed the initial setup instructions and got my units connected to Visual studio code pretty easily.
I ran through the examples of changing the LED colour and then LoPy to LoPy. I am not sure what happened, I can ‘run’ scripts but I can no longer upload them to the boards. I get this message:

Upload failed.: Cannot read property ‘split’ of null.

I also can’t get the pycom upgrade tool to function at all.
I have also tried putting a brand new (untouched) module in the expansion board and trying to run it through the initial firmware upgrade but it hangs at “Getting board information” the same as the other boards.

Hopefully I have just made some sort of newbie mistake. Any guidance would be appreciated.

Hi Aimette,

So neither board can be programmed from the IDE? At least that pretty much rules out a hardware fault if they’re exhibiting similar behaviour. From the sounds of that error, if definitely sounds like a problem in a line somewhere. I saw that you posted on the Pycom forum, that’s a good step. It might be best to wait and see what Pycom say because the hardware sounds ok.

I have installed Atom - which works without issues. I have also installed ampy and that works no problems at all.
I suspect the problem is in a driver/VS code. I am still unclear as to why when I installed VS code on a different computer I see the exact same errors.
The pycom upgrade tool still isn’t working properly for me on either computer.
Is there a way to perform firmware upgrades without the updater? More specifically, changing the LoRa frequency range from 868MHz to 915MHz and visa versa?
Pycom themselves aren’t being helpful.

Hmm, well that confirms that the hardware is ok. Is your version of Visual Studio up to date? I’m assuming you’re following this guide for updating the firmware: ?

I don’t really have any other information other than it sounds like it’s a bug with the Pycom software integration. Did they get back to you at all?

Yes I have the newest version of VS code. Just downloaded yesterday.
Pycom have been silent so far :frowning:

Was it working before you downloaded the new version of VS?

I only started using VS code and pycom boards yesterday.

Right. Well, I’m at a bit of a loss I’m sorry. I’d say give it a couple of days to see if Pycom get back to you, and if not, I’ll see if I can follow that up for you.