NB-IoT / Cat-M(eMTC) / GNSS HAT for Raspberry Pi, Globally Applicable (CE08647)

This is a placeholder topic for “NB-IoT / Cat-M(eMTC) / GNSS HAT for Raspberry Pi, Globally Applicable” comments.

NB-IoT/Cat-M(eMTC)/GNSS HAT for Raspberry Pi, Based on SIM7080G, Globally Applicable…

Read more

Will these work with the Hologram Global SIM cards you sell? It’s not clear from the product description if these can connect to 3G/4G.

Hi Alex,

Hologram SIMs operate on various networks based on what’s available in a specific country. For instance, Hologram operates on 4G, 3G, 2G (though I’m not sure that exists anywhere here anymore), and LTE-M:

This means this HAT should work, though I haven’t worked with Cat-M or NB-IoT personally, so I can only vouch for a Cat-4 product like the one that shows up in our guides:

Let us know if this spurs more questions :slight_smile:

Hi James,

Not quite what I was asking, but I’ve been able to answer my own question.

I was unaware that NB-IoT is a subset of 4G, rather than a separate technology. However, it does appear to require specific carrier support.

In my case, Telstra appears to have support for both NB-IoT and Cat-M devices.

Hadn’t noticed LTE Cat-M1 vs NB-IoT - 4G Connectivity Comparison with IoT Devices - Tutorial Australia yet

2 Likes

Hi, can you tell me, please, if this device will accept/send basic SMS messages on LTE? I can’t access SIMCOM’s docs to confirm this. My use case is to update an existing control system from 3G to 4G operation, using SMS over AT commands, not really in need of the CAT-M/NB-IOT functionality as such.

Hi Andrew, welcome to the forum!

While Waveshare don’t offer application notes for SMS use, I can see the SIMCOM docs show AT commands for sending/receiving SMS for that series of chip:


(Taken from here: https://www.waveshare.net/w/upload/0/02/SIM7070_SIM7080_SIM7090_Series_AT_Command_Manual_V1.03.pdf)

If you want a unit with guides on SMS unit, the Cat-4 ones seem to be better suited to that:

Hi James, thanks for the response. Yes, it implies that it should work, but no examples. I have some physical space restrictions to contend with, so not sure a larger board would be easy to retro-fit. I’ll have a think about it - my solution may require an adapter board anyway to obtain access to UART pins on the existing Particle Electron running the existing code, which could make things more flexible.

Hi Andrew,

This one is a liiiitle smaller if that helps:

A bit of further internet rummaging found this example, using a SIM7080 based device, but also from waveshare (or was)… so I think I will take a punt with the one you’re selling, and see if I can rinse and repeat. Wish me luck!

1 Like

Hi Andrew,

Glad to hear you’re moving forward and giving it a go :slight_smile:

Provided you don’t solder anything or mate any small connectors too many times, and keep all your original packaging, if it doesn’t work out we often accept change of mind returns. More info here: Core - Policies & FAQ Australia

Just an update to note that I have been able to send/receive SMS using an Aldi SIM (Telstra network) with this module on CAT-M1, via the USB interface, so it does support that mode. Didn’t play nice with a Boost SIM (also Telstra network) so not sure why the behaviour is different. Also doesn’t connect on NB-IOT, but that’s the network configuration, I expect (SIM not intended for IOT usage).
Next step is integrating it into my existing code. The lack of a RI pin wired from the SIM7080G is a pain, but I was aware of that when I bought it. I will have to replace some interrupt driven actions with a timer to check for data on the UART port. Not so elegant, but workable. HTH others.

Hey Andrew,

Glad to hear you are making some headway on it! I am unsure as to why specific sims aren’t working, seems like it may be an IOT based block being put in on the providers end rather than anything else as its using the same network.

They love causing confusion at the best of times when it comes to IOT devices unfortunately.

Cheers,
Blayden

Hi,
Has anyone had this HAT working with Telstra through M2M one? I have the sim card working in a 4G router but I can’t seem to get this hat working. I have set the APN in the code using AT+CGDCONT=1,“IP”,“telstra.internet” but when it runs in python it gives back ERROR. I have run the AT command through PUTTY and it gave back OK.
Does anyone have some simple code to get this connecting. I’m trying to get it to send to MQTT to hivemq, so far I can do it over wifi but not NB-IoT.
Cheers
Adam

Hi Adam,

I’ve found this troubleshooting point on M2MOne’s website that might help you narrow down the issue.

If possible check the devices SIM status (menu, GUI, LED, etc) or by issuing the AT command AT+CPIN? The +READY response generally rules out a hardware issues, and an +ERROR generally indicates that there is a hardware/device interoperability issue.

Can you try the at command AT+CPIN? and see what response you get?

Hi Trent,

Thanks your reply. The AT+CPIN? gives back +READY.

Adam

Hi Adam,

That’s promising that the hardware at least is giving a ready message, though it seems to suggest it might be an incompatibility issue with the M2Mone SIM card.

I don’t suppose you’ve got access to another SIM card on a different network you could try to see if it’s a carrier network restrictions that’s preventing you from connecting?

Hi Trent,
Sorry for the late reply, I ended up just using a usb stick. Worked a lot easier.

1 Like