No Com port visible for Arduino/Genunino Uno

Have been using the Uno r3 for a few weeks with no issues. I now have issue uploading a verified skectch with the following error.
Arduino: 1.8.9 (Windows Store (Windows 10), Board: “Arduino/Genuino Uno”

Sketch uses 3258 bytes (10%) of program storage space. Maximum is 32256 bytes.
Global variables use 230 bytes (11%) of dynamic memory, leaving 1818 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can’t open device “\.\COM3”: The system cannot find the file specified.

Problem uploading to board. See for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

I purchased a new Uno R3 thinking I had damaged it somehow and have the same issue with the new board.

I also tried out a new Mega 2560 and do not have the issue.

Are you sure that the UNO is sitting on COM3, devices will usually get the same number when reconnected but they may also move around. If you run mode in a command prompt it will tell you all attached com devices.

Nothing assigned to UNO

Microsoft Windows [Version 10.0.17134.765]
© 2018 Microsoft Corporation. All rights reserved.


Status for device CON:

Lines:          9001
Columns:        120
Keyboard rate:  31
Keyboard delay: 1
Code page:      437


Is that with the Arduino Uno plugged in? If so your Uno driver may have corrupted on the systems I would uninstall all the arduino software and reinstall with the newest version.

I would try this again with a different USB cord, and connected to different ports.

Thnks for you replies.

Uninstalled Arduino software and re-installed , now running
Tried new usb cable.
CMD mode does not show a com port.
Tried a Mega 2560 with same cables etc and ports are available.

I there a specific driver for the UNO r3 that could be replaced or updated?

What does Windows device manager say? Are there any unknown devices shown? What com ports are shown?


Device manager shows com3 only. No unknown devices.



Try reinstalling the driver for the com port. Refer to
and see if that helps.

Also this link may be of use.

Hi Avi,

What were you using your Uno for before it stopped working?

Hi Stephen,

I was running a nema 14 stepper motor.

Hey everyone, I decided to reload win 10 and have resolved the issue.

Thank you for your support.



Spending a day reinstalling Windows is not very productive and not much fun. Do you intend reinstalling Windows every time it breaks?

1 Like

+1 would be easier to update the driver next time :slight_smile:

1 Like

Windows 10 is not so bad I think you can do a fresh install in about an hour, Though you will spend weeks remembering the software and files that you accidentally deleted in the process.