Arduino Uno R3 (A000066)

This is a placeholder topic for “Arduino Uno R3” comments.

The Arduino UNO is the most used board in the family of Arduino boards. If you are starting out with Arduino, this is the board to get.

Read more


I bought an Arduino Uno R3 (along with a USB A to B cable) and received it on Wednesday.
When I connect it to my computer, the on LED lights up and the orange LED blinks, but I get the error “USB device not recognized: The last USB device you connected to this computer malfunctioned and windows does not recognize it”.

The port does not appear in the Arduino IDE so I am unable to upload a program to it, and in the device manager, a device called “Unknown USB Device (Device Descriptor Request Failed)” appears under USB controllers.

I use Windows 10, and I’ve tried this on two other devices and got the same error.

Could I please get some advice on how to get it working? Thanks!

Hi Kevin
I had a USB3 port lock out on me some time ago. I think due to overcurrent protection.
I went into device manager and the port is marked with a yellow ! (exclamation mark). Uninstall it and restart windows. It should re install automatically.

The blinking LED is the small sketch loaded from new by default. It is a confidence thing to show the Arduino is actually working and should be OK.
Cheers Bob

Hi Robert, thanks for the suggestion.

I tried uninstalling the device and restarting windows, but the device just reappeared with the same name (Unknown USB Device). So it seems the problem I’m having is different.

This is the device in the device manager:


Have you installed the right driver? I was looking at the problem, saw this:

It is important to follow the steps mentioned next to be able to use the Arduino
Uno R3 and some other boards. Please check the Arduino website for up-to-date

  1. Plug your board in and wait for Windows to begin the driver installation
    process. After a few moments, the process fails.
  2. Click on the Start menu, and open Control Panel.
  3. In Control Panel, navigate to System and Security. Next, click on System.
    Once the System window is up, open Device Manager.
  4. Look under Ports (COM & LPT). Check the open port named Arduino UNO
  5. Right-click on the Arduino UNO (COMxx) port and choose the Update
    Driver Software option.
  6. Next, choose the Browse my computer for driver software option.
  7. Finally, navigate and select the Uno’s driver file, named ArduinoUNO.inf,
    located in the Drivers folder of the Arduino software download (be careful:
    not the FTDI USB Drivers subdirectory).
  8. Windows will finish the driver installation from there and everything will
    be fine.

I don’t know this will fix your problem. I just found it online.


Hi Alan,

Unfortunately, Arduino UNO does not appear under Ports (COM & LPT). Only “Communications Port” appears, but this has nothing to do with the Arduino (it remains even after I unplug the Arduino).


Maybe you have a dirty USB socket. If you have a volt meter, you could check the UNO is getting 5V. Or swap to another USB socket, see if anything changes. If you haven’t previously plugged the UNO into a port, you should get the standard “looking for a driver” message. At which time you can let it find the correct .inf file in the Arduino distribution.

1 Like

Hi Kevin,

Sorry to see you haven’t resolved this one yet! The last thing I’d try is a different cable. Arduinos are almost certainly tested exhaustively after manufacture, but a bad cable is harder to notice.

If that doesn’t resolve it, reply to your order email and we’ll sort out the RMA process for you.

Hi James,

The issue is now resolved - I didn’t have the chance to try these fixes the past few weeks, but yesterday I bought a new USB A to B cable from a separate store and the Arduino worked when I used that.