Uno board not recognised by Mac or Windows

I have one of these

Which is not recognised (can’t select a port through Arduino IDE application) on Mac (Mojave, OSX 10.14), or Windows 10.

I’ve tried installing the CH340 driver, and removing old drivers, combinations of the two etc.
sudo rm -rf /System/Library/Extensions/usb.kext
sudo rm -rf /Library/Extensions/usbserial.kext

Nothing has worked.
I don’t have admin privileges on the Windows machine but was just using it to check if it might work without drivers. It does not.

Any ideas?

Hi Beth,

Have you installed the Arduino IDE? It installs the drivers as part of the package. What does the Uno show up as in the device manager, and also, have you tried a different USB cable?

Yes, I have the Arduino IDE installed
(can’t select a port through Arduino IDE application)

I do not have any other USB cables that I can use that will fit into an arduino.

In device manager it shows up as “Unknown USB Device (Device Descriptor Request Failed)”

This may not help and probably you have already tried. Windows Machine.
Uninstall the device in Device Manger and also the software if it allows you to.
Unplug and re-plug the UNO, maybe in a different USB port.
Just did that and my UNO shows up as :-


It did not show up in USB area.
Uninstalling has sometimes worked for me.

Having Admin on Windows would help to remove drivers and re-install.
Cannot help with MAC, no experience there.

If you have tried different computers and USB ports and different cables; maybe the board is faulty. (would not think so, though) You have said you only have one cable, I assume this works with other devices. Maybe try a different cable if you can get one.
The UNO uses a version of the ATMega chip to do the USB stuff; surface mount chip, located near the USB socket. If it is not programmed correctly the USB may not work. Have never seen or heard of this chip being programmed incorrectly.

Also, if you have access to another UNO that might help prove a faulty UNO; if it works, of course.


1 Like

Found another USB cable, yep it was the cable - now both windows and mac recognise the board. Thanks for all your help :slight_smile:


Glad you got it working Beth!!