Uno R3 SMD not recognised by Ubuntu 20.04.2 LTS or Windows 10

Hi there,
I have got a brand new Uno R3 SMD and cannot get it to connect to either Windows or Ubuntu. When I plug the USB cable in with another Arduino R3 (standard, i.e. non-SMD), this is what I am see:

❯ dmesg | tail -n 5
[269275.004373] usb 1-1.1: New USB device found, idVendor=2341, idProduct=0043, bcdDevice= 0.01
[269275.004375] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[269275.004375] usb 1-1.1: Manufacturer: Arduino (
[269275.004376] usb 1-1.1: SerialNumber: 55736303831351813292
[269275.011640] cdc_acm 1-1.1:1.0: ttyACM0: USB ACM device

However, when I disconnect that Arduino and connect the one that is causing me issues, this is what I get:

❯ dmesg | tail -n 5
[269384.871346] 8313966 pages RAM
[269384.871348] 0 pages HighMem/MovableOnly
[269384.871348] 166438 pages reserved
[269384.871350] 0 pages hwpoisoned
[269452.320023] usb 1-1.1: USB disconnect, device number 33

Device Manager in Windows is also unable to see the Uno R3 SMD. From the research that I have done, I think that this could be related to a faulty FT232RL on the Arduino. I only have one other genuine Arduino (Mega 2560) and that works.

I am using the same USB cable between Arduinos. Any ideas?



A bit more information:

I have moved the USB cable to another USB port and get the following:

❯ dmesg | tail -n 5
[270417.698109] usb 1-3: New USB device found, idVendor=03eb, idProduct=2fef, bcdDevice= 0.00
[270417.698110] usb 1-3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[270417.706953] usb 1-3: usbfs: process 10343 (fwupd) did not claim interface 0 before use
[270417.709628] usb 1-3: usbfs: process 10343 (fwupd) did not claim interface 0 before use
[270417.712006] usb 1-3: usbfs: process 10343 (fwupd) did not claim interface 0 before use

The Arduino application cannot see the Port (presumably because it wasn’t initialised correctly)

Again, thanks for any suggestions.



Hey Ricardo,

Welcome back to the forum! Sorry to hear you’re having issues with that one. It’s sounding like it could potentially be an issue with the driver.

If possible, can you send a screenshot of what’s appearing in Device Manager on the Windows PC when you plug the board in?

Hi Owen,

I can try to do that again later when I get home, but I have tried a few times previously and the COM port is not appearing in Device Manager under Windows 10. Also, wouldn’t the driver be the same as that used for the other Arduino Uno R3 (non-SMD) and automatically installed with the Arduino software?



Ok, I have experimented again with the board on my Windows 10 laptop and noticed that it keeps discovering the device (albeit not being able to identify it) and then it disappears again from Device Manager. Windows is cycling through playing that tune that it plays when you insert a new USB device.

Neither Zadig or Device Manager can identify the device, as shown below:

Device Manager


My other Arduino works fine and this is what I see when I plug that into the laptop using the same USB cable:

Do you think that I may have gotten a dud?



…and I have also tried using my USBasp programmer but to no avail…

Note that this is successful in programming my non-genuine Arduino Nanos… I am fairly convinced that I have got a dud…



1 Like

Hey Ricardo,

I was just doing a quick bit of research into this and the Uno R3 SMD doesn’t actually use the same FTDI chip for the USB to Serial connection as a standard Uno used to (the Uno moved onto an ATMega8U2 and has since updated to an ATMega16U2). The Uno SMD uses a preprogrammed Atmega8U2 that is used solely as a USB to Serial converter.

It’s possible that the firmware for this has become corrupt. There is a bit of a way around it though, if you take a look at this page it will step you through how to reprogram the chip.

Another quick troubleshoot to do would just be to isolate the potential variables (e.g. USB cable used, USB ports used, etc.)

Hopefully this gets you a resolution!

1 Like

Those USB messages are what you get from an Arduino that hasn’t been flashed assuming the cable and port are OK. You’ve already tested the cable and port and have used another arduino so my guess is that the UNO needs to be reflashed. There’s lot of examples around on how to do it but given you have another device this should help you to do it: