Pi 400 - no sound

Gday Folks, hello! Im a newbie to the site and forum.
Ive been a user of Pi’s since 2 came out, however this question is about the cool looking Pi400 I have purchased for a friend who wants to use it with Kodi.
I received yesterday and I have set everything up, however I am getting no sound.
O/S - Downloaded latest Raspberry OS - when installed also downloaded and installed latest updates.
TV for testing is very good - have a Pi2 in the other HDMI port of the TV and getting sound.
Swapped HDMI ports on the TV - still getting sound from Pi2 but not Pi400.
Tried mp3’s via VLC player that came with the OS - playing but no sound (was 100% on VLC volume meter);
Tried through Kodi - (volume at full) - no luck.
Tried switching HDMI ports (someone suggested must use the one close to SD card slot) - no luck.
Switched cables - nope.
Any tips?
Thanx in advance

PS: It was purchased thru CE (very quick delivery!) - buyers email is bretts.____@gmail.com, Gloucester :slight_smile:

There are settings for some HDMI audio features in config.txt listed here:

Particularly hdmi-drive and hdmi_force_edid_audio

Nice to hear from you again Oliver.
OK, in the config.txt file;
#hdmi_drive=2 is already there.
#hdmi_force_edid_audio=1 was NOT in the file, so I loaded it - no change so I reverted back.

I noticed that

Enable audio (loads snd_bcm2835)

. . . . didn’t have a # infront of it and was grey (not green) in the editor - included the # but no change with that either :frowning:
After 8 hours I’m getting a little frustrated - would appreciate anymore tips or help - I’m not the best person to trailblaze.
Thanx in advance

1 Like

I still had some bourbon left in the glass when I wrote the last comment, so I did a bit more research and found this:

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment the #hdmi_drive=2 just remove the # so it looks like this:


Tip: I powered down the Pi400 and removed the sd card and put it into the PC where I edited with notepad - was a lot easier.

Good luck and thanx for your help Oliver :slight_smile:


Great! Glad to hear you got it working :slight_smile: