Core Electronics Forum

Raspberry Pi 4B 4GB Not Booting

Hi All,
I bought a Raspberry Pi 4B 4G with the official HDMI, SD Card with Noobs, and power supply.
Unfortunately, the Pi won’t boot. I have tried the following tips already:

I have Pi 3 and all the SD cards I’ve worked with it, so I assume the issue it’s not with the SD Card.

Also, I have made a video about it for this post:

And lastly, after reading this post, I can’t say what is the root cause nor how to fix it.
https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=58151

Any tips on how to solve this issue?

Thank you very much for your support in advance.

1 Like

Hey @ValterHenrique92403,

Hmmm, this is a tricky one, let’s start with the SD card. Just because the SD card works on the Pi3 doesn’t mean it will work on the Pi 4. (ie backwards compatible not forward compatible). With this said I would take a look at this tutorial which will allow you to definitively upgrade your SD card. I will tag @Clinton as he is our resident RPi guru.

Let us know how you get on.

Hi Gordon, thank you for your reply.
I’ve tried to upgrade as you recommended but it didn’t work. Also I’m trying the new Raspbian version, Buster and it’s not working. The SD card in question is the one I purchased here at Core Eletronics ( 16GB MICROSD CARD WITH NOOBS FOR ALL RASPBERRY PI BOARDS), so I assume it’s a legit and valid SD card.

I really don’t know what to do anymore… any other ideas?

Thank you for your support once again.

Sounds like you’ve tried all the normal things to get the RPI going, we can take a look by using official hardware and see what part is not working.

Reply to your order confirmation email and link to this forum topic.

Hey Graham,
thanks a lot for the support mate.
I’ve contacted support already, they are reviewing my case.

1 Like

Bugger.

Yeah me, also.

Although, I was a cheapskate and didn’t buy the official power supply and HDMI cord. (I have USB C devices all over the house and all I needed was a HDMI to Micro-HDMI, which Jaycar supplied.)

On top of that, I have done everything, to the letter contained in the Official Raspberry Pi forum’s sticky, lined by https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=58151.

I’ve already emailed support, so hopefully will have an answer soon so my wife can have our dining room table back (It’s now a construction zone! :slight_smile: )

I hope @Clinton can help me out, too.

I would have a look at the micro HDMI cable, make sure that none of the pins are damaged.

It’s not the HDMI cable. The green light comes on for a tiny time, then nothing. Even when theres nothing plugged in at power up.There’s no activity, it cant be a display issue.

this may sound silly but not unheard of…make shore your screen is turned on before you power on your rpi-4…and the correct input selected via its menu if it has several types of inputs…
also just a tip …use etcher to flash your media…and make shore your flashing it on an x86 64 bit machine …
…also try a different screen…

I have seen an issue there the HDMI lead is shorted so the Pi will not boot at all, It took us a while to find it because as mentioned does not appear to be a display issue.

Hi,

I too had this problem, trying numerous SD cards, different HDMI monitors, and now need to seek out hair transplant services. :slight_smile:

I won’t put it down to a faulty Pi as overall I have had very little trouble with them. The only two things I have not yet replaced are the power supply and the microHDMI cable. The power supply is the genuine Pi one, and the MicroHDMI cable was from Core as well - one of the recommended accessories so I assume they are fine.

The symptoms I get are

  1. no display on the monitor at all.
  2. Green LED on the Pi flashes 4 times over 2 seconds or so, then repeats. There is no change to this pattern - not even as though it were booting off the card.

I cannot find the link now (this is similar), whereby I created an SD card image that is suppose to resolve this problem because the firmware may need reloading. Instructions read to boot this small image, and the green LED will flash faster when complete. This didn’t change, so I’m not sure what to do next.

Anyway, just putting my ten cents worth in - hopefully it helps somebody and between us we can find a solution.

Oh, and by the way, theres some problems with Etcher at the moment on the latest Mac OS versions, so this is a pain in the next too.

Greg

I would definitely try powering up without the hdmi connected and see if it changed in behaviour. If you still have problems, contact Core Electronics with a photo of the board and the ends of the HDMI cable (so the pins can be seen).

Hi Clinton,

Hopefully both brand new cables aren’t faulty, but not out of the question.
I’ll try booting without the HDMI cable to see.
What will the Pi do if the cable is shorting, I boot it (and it appears to do the right thing) and THEN plug the faulty HDMI cable in? Will it still display or will the Pi reboot?

Greg

Hi everyone,
I’ve sent my faulty Pi back to Core Eletronics and after an inspection, it was deemed faulty and a replacement was sent to me, and this one is also not working… (by that I mean, no output, no video).
Tomorrow I will try to buy a new HDMI/micro-HDMI cable because that’s the only thing I can think of as the problem.

Overall, I’m very disappointed with the lack of quality of this new Pi, nothing works apparently. My family spent $175 on this (cable, sd card, pi, etc) for what? … If the new HDMI cable doesn’t work, I won’t buy Raspberry PIs anymore.

I apologize for the negativity in my comment but it’s just too frustrating…

I appreciate the support given by Core Eletronics so far, you guys are terrific.

I’ve found Raspberry Pi hardware to be consistently reliable in the maker industry. The boards are made at Sony in Pencoed and are electrically tested well beyond a power-up before boxed. The production line and testing systems were some of the best highlights when I visited last year. Sony has incredibly high quality control practices that exceed any other maker-manufacturing process I’ve ever seen.

Getting two in a row DOA, well, that’s just so unlucky! It’s very likely something else is going on, possibly with the HDMI connector (might have lifted pins inside creating a short and damaging the freshly electrically tested RPI?). Unsure. Though the odds are well-against two electrically tested RPI boards being DOA.

It might also be the dsiplay isn’t fully HDMI compliant and needs hotplug to be setup in config, umungst other problems with older HDMI displays.

The HDMI cable is the official, I bought it from Core Eletronics.

try this and see if it boot`s up at all…

https://www.raspberrypi.org/forums/viewtopic.php?f=131&t=256192#p1563150

Sadly, my Pi is back with CE for testing.

i literally tried everything listed here with the exception of another screen (we don’t have another screen to test it on)

I have even tried stuff from YouTube including changing a boot file on the Raspbarian bootup card.

All to no avail.

I’ve told them that if the Pi isn’t faulty, I will “run” a lap of the Newcastle V8 Supercars circuit in a pair of speedos (bad enough, trust me…).

At the very least, I decided that even if it was found to be ok, having someone to load Raspbarian on their would be worth the money.

No word back at this stage.

I’m reading across the internet that the RPi are actually failing at a greater rate than normal. Sometimes, when a new model of something comes out it’s not 100% perfect like the last one.

I just hope they’re not going to be like Toyota who make genuine parts to resolve issues then blame everything else for their own issue.

Having said that, I have been impressed with the way CEhave handled my issue.

As I said before it’s not got the activity light on boot up even when there’s nothing pluggd in, which leads me to believe it’s not a display issue.