Pi Zero W -Wireless and maybe Bluetooth not working

Hi - I have a few Pi Zero Ws that I have configured for family members. The last two worked brilliantly.
The first has never recognised the WiFi device, so could not connect. It was bought in May this year.
Some rumours suggested that the early ones may require a firmware update to enable the WiFi and Bluetooth.
Could you shed some light on this issue?
Scanned the forums and did not see any mention of this issue.

Keep on Making!

Hey @David38530, before we go down the troubleshooting rabbit-hole, can you please clean your SD card and then install the latest version of Raspbian using NOOBS.

This may be all that is required.
If not:
If you have a WiFi dongle floating around (to use temporarily) you can plug into your PZW and connect to a network, then grab a firmware update by executing the following:

sudo apt-get update
sudo apt-get upgrade
sudo rpi-update

The early-released PZWs did seem to have a few where the onboard WiFi was not detected. Sadly, I don’t have my hands on any to roadtest any fixes.

This github issue documents the issue around when it was noticed, and details some filesystem hacks that apparently fixed it - this involved modifying/replacing files in the boot partition. I don’t fully understand what is going on but it seems that there are just some wrong hardware definitions.
I’ve avoided quoting the topic directly because it is quite lengthy, but a resolution is found in the first couple of posts. If following along does prove necessary, and works for you I’ll edit my post to include the information for posterity.

Thank you for the prompt reply.
I am aware of the Github issue.
I’ll get on to it in the morning when the head is refreshed and I’ve had a
good strong coffee. I’ll post as many details as I can (Long time IT
Sysadmin so I keep a notebook beside me always!)
I’ll use a new SD card and latest NOOBS.
David (DJ)

No luck with your suggestions. I think that I tried that but followed yours
exactly - I may have strayed a bit! :slight_smile:
Alea jacta est.
I’ll go githubbing in the morning - it is already past midnight here and it
is a full moon. I have werewolves to seek…

DJ (the Mad IT Monk)

Let us know how you go DJ.
I had my hopes that NOOBS would perform some firmware magics - I’ve seen positive results in other forums with this issue.

If you strike-out, send us a reply from your order confirmation email linking this post and we’ll figure out the best way to proceed.

Thanks Micheal
This is a machine for starters… the WiFi is not important
Fertilizer occurs…

No success with anyting - guess thiis is no-WiFi


Ummm - can I put it in a bag to you? the firmware is not up to spec. Sorry.

Just shoot us a reply to your order confirmation email, linking this post and we’ll be in touch.