PPP Interface with a CE07312 NB-IoT / eMTC / EDGE / GPRS / GNSS HAT for Raspberry Pi

Hi there

I have been playing around with the NB-IoT / eMTC / EDGE / GPRS / GNSS HAT for Raspberry Pi
I am trying to create a PPP interface on the Raspberry PI, using this NB-IoT HAT, with the SIM7000E.

The other night, I succeeded, and it worked perfectly all night doing test calls to various services on the internet.
I then power cycled the rpi&HAT, and for the life of my, I have not been able to establish the PPP connection again. I think I am missing a key AT Command or sequence is wrong, as I was manually recording the AT commands, and I must have just dumb luck scored the correct sequence.

The SIM is the correct (large) size in the holder.

Does anyone have the correct AT Command Sequence to establish a PPP connection to create a PPP interface on the RPI?
I am using telstra.iot configured SIMs, and like I said they worked the other night.


+CNACT: 1,“”

As you can see, I am getting an IP address.

I also tried this sequence of AT commands

likewise, I get an IP address here.

I’ve just been using the standard gprs pppd and chat scripts, making use of the manual AT commands I issue in minicom - I do plan to automate the AT commands, in the chat-script, after I know what the correct ones are.

Thanks in advance.

Cheers MG

1 Like

Hey Mark,
Welcome to the forums!

Seems if it was originally working you should have most of the commands pretty well good. One thing to check is all of your SIM details, unfortunately, some providers change things on occasion and things like your Authentication type, Access Point /Private Network Names or SIM number may have changed. That would be the best first step to rule out any changes on their end by logging in to your Telstra account and cross referencing what you have set up with the hat already.

After that ensure that the commands you are giving are specific to your advice as per the waveshare wiki for that particular hat, this can also be a significant issue when working with devices like these.

Are there any errors in the logs that are coming back, or is it just pushing through with an ok but failing to work?