Core Electronics Forum

Qduino 'port' not showing on IDE

hi, I am trying to put the code into the qduino,
Qduino port was showing and the code ran for a couple of days after then suddenly it is off and the port is greyed out. I haven’t done anything and it suddenly did that. I tried reinstalling the driver and reinstalling Arduino but it is not working. The cable that I use for Qduino works with particle photon so I don’t think it’s the cable (Still not sure). I have also tried restarting the computer but that didn’t work as well… it is a brand new qduino and i have only tried couple of times running the code. What can be the issue here? and solution?

Does anybody know how to burn the bootloader onto the Qduino using an Arduino as ISP? someone recommended me this method but I don’t know how to do it.

Thanks in advance

Hi Jinkyung,

Hmmm, that is odd. I would recommend reinstalling the board for the boards section of the IDE. Also, check that the Qduino is showing in the device manager under Universal Serial Bus Controllers or Devices.

Here is a tutorial showing you how to reinstall the board in the IDE. If this doesn’t work, please share some photos of your setup. Hope this helps!

2 Likes

Yeah I tried looking up , Qduino is not showing. I don’t think it’s being recognised at all by pc because it usually makes this noise when a cable is plugged in but there’s no noise when I plug in qduino. Only the power light is on. I even tried with a different cable, and a different pc. Arudino uno is recognised with both pc and cable but the qduino is not being recognised at all. I think it is qduino problem ( just my assumption).

I have already tried reinstalling it , didn’t work.

what do you mean by show photos of my setup?

Thank you

Hi Jinkyung,

[quote=“Jinkyung128517, post:3, topic:8440”]
what do you mean by show photos of my setup?
[/quote]If you could post some photos of how you’ve got your Qduino physically connected and wired up that would help us greatly in troubleshooting your issue.

PS. I see you’ve made quite a few separate threads on the forum, it’s best to keep everything in one place if you can so others know the history of what you’re doing and what you’ve already tried.

Regards,
Oliver
Support | Core Electronics

1 Like

Hi Jinkyung,

There are many reasons why something electronic, that is fairly new, suddenly fails. It is very difficult for persons on this forum to help without some understanding of the situation or detailed information concerning the problem.
I and many others on this forum have a good understand how the Qduino works, how the microprocessor works, how to program it, etc. But we are not sitting in front of the one you have or know how you have it set up. A very minor thing may be why it is not working.

Example: yesterday I reconnected a stepper motor circuit, it did not work as it previously had. The solution was very simple, I had simply placed one jumper wire in the row next to the one it should have been in on the breadboard. (lighting and eye sight not good I put it down to)

Reprogramming the bootloader should be a last resort. It is not an easy process, needs a special programming device, a good understanding of what you are doing and it can lead to completely “bricking” the Qduino if not done correctly. (first time I tried, I bricked the Arduino, but later fixed it) Suggest trying this with a cheaper device, something like:-

Nick Gammon has made some very good tutorials on programming the Arduino. These should help you understand what the bootloader is for and how to load it. With respect to the Qduino Nick does not have information because the device most likely did not exist at the time. But the principle is the same.
There is a second issue with the Qduino, the pins for bootloader (ICSP) programming are available on the board but you need to make a cable to suit. You need to be very careful that the pins are correctly wired. Modern electronic devices can tolerate some incorrect wiring for a little while but not for ever.

BUT RELOADING THE BOOTLOADER IS THE LAST RESORT.
I would only attempt it after exhausting all other possibilities.

Regards
Jim

2 Likes