Core Electronics Forum

UNO R3 Board

Hi
My UNO board has stopped working. When I plug it into computer it does not register any Port connection. I have tried all usb ports. This has happened on both my desktop and laptop. Power light is on as are TX/RX led’s ( not very bright), but no illuminated L led. I did try a reset, no joy. I also plugged in a 9v battery and all led’s on board then illuminated, but no port detected.

Hi Andrew,

First off, please double-check using a different USB cable
Second, please ensure that you are running the latest Arduino ide, installed on your pc and not from the zip.
third, try a different computer
Also, make sure your drivers are up to date.

I would also check in device manager, this can be done by pressing WINDOWS + X and the checking under COM Ports

If it is not under COM Ports it may be in Universal Serial Bus Controllers or Devices

Regards,
Mitchell

Hi Mitchell,
Done all that. It was working fine last night and not now. The board is not registering with computers, desktop and laptop. Latest IDE is being used. it has been using port 11 on desktop and port 4 on laptop.

So I uninstalled the IDE, cleaned up and then reinstalled. Still the same problem.
Uno is not being detected.

The chip circled is the interface between the Atmega328p and the USB port.
If this chip fails or loses its program the UNO serial port would not show up on the PC.

It’s possible to restore the firmware to this chip but its not an easy process.
Considering the cost of a UNO clone ($13.20) its usually not worth trying to fix a dead one.

Also, the Atmega328p might be causing a problem (unlikely but a possibility). I tried connecting a UNO without the Atmega328p and the port showed up on the PC. You could remove the Atmega328p (carefully) and plug the UNO into a PC. If port still does not show up then the chip circled is faulty as I said.

All the best, just some ideas, if I was in your situation.
Cheers
Jim

Hi James,
Thanks for that info. Will give your solution a go. If that does not work will ring supplier. Only bought the board 2 weeks ago.

Cheers
Michael

Still no Joy

Hey Michael,

Okay, was that board from Core Electronics, if so please email support@coreelectronics.com.au and we can have this sorted out for you right away.

Bryce
Core Electronics | Support

Hi Bryce,
Yes it was. Order number was #100232805

I have already emailed Support(16/09) about this and got pushed to the Forum,.
Not exactly happy with that outcome.
Seems that the USB Contoller is dead.
Borrowed another Uno and it connected to both Desktop and Laptop straight away.

Cheers
Michael

Hey Michael,

That’s okay, usually, issues like this occur from the way in which the device is connected or how the IDE is setup. But in this case, the Uno appears to be faulty. I’ll have a replacement sent out on us for you right away. We’ll be in touch soon! :slightly_smiling_face:

Bryce
Core Electronics | Support